Unable to find/create an image that can publish .Net core 3.1 x86 application

I’ve been pulling my hair out for weeks now… - I have a ASP.Net core Web API that MUST be built in x86.

Everytime I have asked for help from places like stackoverflow / fb groups / friends from work / other forums the response has been along the same lines

  1. they either repeat bad my issue (like that helps!!)
  2. or they just say use the Microsoft’s dotnet/aspnet “it says on the docker hub x86”

I have tried every dotnet/aspnet version i can find, I always get the same BadImage Error.
It works fine if i change the project to AnyCPU - but as i mentioned, for the application to work bug free, it MUST be in x86 (it uses Assembly to read 32bit dll’s)

I have also tried to download linux dotnet binarys, COPY them into the container and run them directly but that gives me a new error - “/lib/ld-linux-armhf.so.3 no such file or directory”

I found a BuildDotNetCore.sh file that appeared to manually add the files i need, but couldnt get that working either.

Please, if anyone has an ‘idoits guide’ on how to get this working, i’d be very gratefull

Thank you