[HELP] DockerHUB Automated Build - NET 6.0 sdk/dotnet images not found


I’m trying to use hub.docker automated build system for my NET Core 6.0 app. It is building from github repo and in Dockerfile I tried using Microsoft Artifact Registry with both 6.0 and latest tag.

For 6.0 version it throws an error that I found in the log that it does not find this sdk image version. With the “latest” tag it uses 3.1.32 version instead which is way too old.


By looking through the supported platforms for each version I assume the server machine DockerHUB uses for the automated builds is running on some very old OS version that just does not support the needed sdk docker image version and the latest it supports is 3.1.32? Everything builds and runs fine on my different local Windows, Linux and Mac devices so the issue is not in the project code or Dockerfile. They pull the required 6.0+ version sdk image just fine.

Please share the exact commands you used, so we can see what you actually tried.

Sorry for the misunderstanding. It was my fault.

For the sdk image in Dockerfile I used: (copied from my old project)


instead of:


The former is deprecated it seems to me. Latter is being kept up to date.

Everything is solved now! Thank you for the willingness to help.

1 Like