Unable to install Docker Desktop

Windows 11 (22H2)
Docker Desktop v 4.17.1
WSL2 is install and working (Ubuntu distro is version 2)
Fails when weather WSL2 option is selected or not.
Tried the wmi fix and sfc scannow

Component CommunityInstaller.EnableFeaturesAction failed:
at CommunityInstaller.InstallWorkflow.d__30.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at CommunityInstaller.InstallWorkflow.d__23.MoveNext()

It seems like you are encountering an error while trying to install Docker Desktop on your Windows 11 (22H2) operating system, even though you have successfully installed and configured WSL2 with Ubuntu 2 distribution.

You have already tried the “wmi fix” and “sfc scannow” methods to resolve the issue, but it did not work for you.

The error message you provided indicates that the installation process failed at the EnableFeaturesAction step of the CommunityInstaller component.

Unfortunately, this error message does not provide enough details to identify the root cause of the issue. However, there are a few steps you can try to troubleshoot the problem:

  1. Make sure that your Windows 11 system is up-to-date with all the latest updates and patches.

  2. Try disabling any antivirus software or firewall that may be blocking the installation process.

  3. Try running the Docker Desktop installer as an administrator.

  4. Check the Event Viewer for any related errors or warnings that may provide more information about the issue.

  5. Try uninstalling any previous versions of Docker or Docker-related software that may be conflicting with the installation.

  6. You may also try to clean up your system using a tool such as CCleaner or Windows Disk Cleanup to remove any temporary files or leftover registry entries.

I hope this will help you.