Unable to install Docker in Fedora 37

I am not a linux or network person but still interested to install Docker in Fedora Virtual box in my mac laptop.

I have installed Fedora 37 in Virtua BOX 7 Where I have done the port forwarding at virtual box level. Screenshot is attached.

Now Once Fedora 37 workstation is installed on top of virtual box. I tried to get a shell access as below in my host mac OS.

Last login: Mon Feb 13 06:11:26 2023 from ::1

[liveuser@localhost-live ~]$ su - root
[root@localhost-live ~]# dnf -y install dnf-plugins-core
[root@localhost-live ~]# dnf config-manager \
    --add-repo \
Curl error (60): SSL peer certificate or SSH remote key was not OK for ******docker-ce.repo [SSL certificate problem: unable to get local issuer certificate]
Error: Configuration of repo failed

When I tried to add repo “docker-ce.repo”, unable to resolve the certificate issue.
Requesting your help in this to move forward.

I didn’t understand your message as the shared commands didn’t make sense. I had to edit and fix your post to use code blocks so the forum does not change it. Please, always use code blocks for quoted codes, terminal outputs, log messages or it is likely that you don’t get a reply if nonbody understands the question :slight_smile: Check your message after posting and edit it if it is necessary.

About the issue:
I searched for the error message and found this