Docker Community Forums

Share and learn in the Docker community.

Unable to install/use Docker Desktop after failed update

I am running Docker on a Windows 10 Enterprise computer. Everything was fine until I rec’d a notice that an update was available. I skipped the past few updates and figured that it was time to get up to date. When I ran the update, it failed (I forgot to snap a pic of the error message). Afterwards, Docker would no longer run. I manually downloaded Docker from the main site and tried installing it.
The installed unpacks the files, creates the docker-users groups and then adds my user ID to said group. Afterwards, it seems to fail when trying to start a service:

I’ve tried multiple re-installs to no avail. I tried cleaning out Docker from the computer but that doesn’t seem to work either. It’s not showing up under add/remove programs. I tried deleting Docker folders and even running a script that I downing from another post (that seems to clear out the install)… but I still get the same error when trying to install the software. At this point, I’m completely out of ideas. Can anyone offer some advice on how I can get Docker back up and running again?

So here’s an update on the issue. After scouring the web, I found that I could get Docker Desktop successfully re-installed if I disabled the “Power” service in Windows. The problem is that once I re-enable to service, Docker stops loading after a reboot. Anyone have any ideas on how I can get Docker Desktop to run while the Power service is also running?