Docker Community Forums

Share and learn in the Docker community.

Unable to launch Docker


(Ozab) #1

Hello everyone - Below is the message that we get opening Docker. Any help will be greatly appreciated.
Windows 10 machine

Unable to create: The running command stopped because the preference variable “ErrorActionPreference” or common parameter is set to Stop: Failed to create the virtual hard disk.

The system failed to create ‘C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MobyLinuxVM.vhdx’.

Failed to create the virtual hard disk.

The system failed to create ‘C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\MobyLinuxVM.vhdx’: General access denied error (0x80070005).
at New-MobyLinuxVM, : line 222
at , : line 385
at Docker.Backend.HyperV.RunScript(String action, Dictionary`2 parameters) in C:\gopath\src\github.\docker\pinata\win\src\Docker.Backend\HyperV.cs:line 177
at Docker.Backend.ContainerEngine.Linux.Start(Settings settings) in C:\gopath\src\github.com\docker\pinata\win\src\Docker.Backend\ContainerEngine\Linux.cs:line 123
at Docker.Core.Pipe.NamedPipeServer.<>c__DisplayClass9_0.b__0(Object[] parameters) in C:\gopath\src\github.\docker\pinata\win\src\Docker.Core\pipe\NamedPipeServer.cs:line 47
at Docker.Core.Pipe.NamedPipeServer.RunAction(String action, Object[] parameters) in C:\gopath\src\github.\docker\pinata\win\src\Docker.Core\pipe\NamedPipeServer.cs:line 145


(Mario Pietsch) #2

Hi, Can you open the path: C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\ with your file explorer and create a eg: test.txt by hand?


(Ozab) #3

Yes. I can create a text file at the following location.
C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks\


(Ozab) #4

Anyone else has any inputs?


(Mario Pietsch) #5

hmm, Did you manually mount the .vhdx file with the explorer? … I did play around with those files and had problems to access them afterwards, because the file explorer blocked them. But that should be a different error message. …

Restarting the PC did help.


(Ozab) #6

We have rebooted, re-installed, tried another Windows profile as well. Still no luck.


(Ozab) #7

Anyone has any other ideas on this?