Docker Community Forums

Share and learn in the Docker community.

Unable to pull Docker images

beta
dockerhub

(Shashanksinha) #1

This was working fine earlier but now I am facing this issue. Internet connection is working fine and there is no proxy configured on my system.

***DiagnosticID:- B562D6B2-46E7-4351-95CB-59D7A082B8DF/2016-07-19_17-00-06

Information

PS C:\Users\Shashank> docker pull centos
Using default tag: latest
Pulling repository docker.io/library/centos
Network timed out while trying to connect to https://index.docker.io/v1/repositories/library/centos/images. You may want
to check your internet connection or if you are behind a proxy.

##############################################################
-Windows 10 Pro

PS C:\Users\Shashank> docker info
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 1.12.0-rc3
Storage Driver: aufs
Root Dir: /var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 0
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: host null bridge overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options: seccomp
Kernel Version: 4.4.14-moby
Operating System: Alpine Linux v3.4
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.951 GiB
Name: moby
ID: GREC:54RV:GSZ5:YZMQ:SOE3:CVEX:34KD:GEFW:UUKL:3UWW:DUBN:ME6Y
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Experimental: true
Insecure Registries:
127.0.0.0/8


(Warawut Meesupa) #2

I was solved this problem by set DNS Server to 8.8.8.8


(Shashanksinha) #3

@iicmaster I had tried this setting and it is still not working. Also I have tried suggested solution from this post

Maybe this has something to do with frequent beta updates I am receiving.


(Mayerwin) #4

Same issue here :frowning:

Update: I got it working with pure default Docker configuration (no manual DNS set to 8.8.8.8, no IP V6 deactivation), by removing Unlocator-related settings from the router (its specific DNS server, and maybe more problematic, static routes that redirected 8.8.8.8 and 8.8.4.4 to the router itself as recommended to get Chromecast working)! I had to reboot the router afterwards and disable/re-enable local network adapters. Strange that Docker is the only application which encountered issues because of this set-up.


(Shashanksinha) #5

@mayerwin I just fixed it. For me it was due to multiple network adapters.