Docker Community Forums

Share and learn in the Docker community.

Unable to pull image


(Zenwanger) #1

As can be seen I am getting an ApplyLayer device error “no space left”. Could this be due to insufficient RAM?

#> docker -v
Docker version 1.7.0, build 0baf609

#> uname -a
Linux vlsj-djap1 3.10.0-229.7.2.el7.x86_64 #1 SMP Fri May 15 21:38:46 EDT 2015 x86_64 x86_64 x86_64 GNU/Lin

#> docker pull ip-:8080/my_image
Pulling repository ip:8080/my_image
67e3b8abe629: Error pulling image (latest) from ip:8080/my_image, ApplyLayer exit status 1 stdout: stderr: write /grid/per.so: no space left on device per.so: no space left on device 91fd9de: Download complete
294e8fa754f2: Download complete
1d8253a13d08: Download complete
a8c87b39b25c: Download complete
d53f4311518c: Download complete
82f69ebaa5e2: Download complete
4ab5c9c628e0: Download complete
96ed3d94a93b: Download complete
a86fc0609c66: Download complete
b7b06ef4050b: Download complete
fc8d137f6164: Download complete
6eae7d7a2adc: Download complete
a60a4d761bed: Download complete
5c45a29f11d1: Error downloading dependent layers
Error pulling image (latest) from ip:8080/my_image, ApplyLayer exit status 1 stdout: stderr: write /grid/per.so: no space left on device

#> docker info
Containers: 6
Images: 22
Storage Driver: devicemapper
Pool Name: docker-8:3-212080599-pool
Pool Blocksize: 65.54 kB
Backing Filesystem: xfs
Data file: /dev/loop0
Metadata file: /dev/loop1
Data Space Used: 9.566 GB
Data Space Total: 107.4 GB
Data Space Available: 27.06 GB
Metadata Space Used: 6.115 MB
Metadata Space Total: 2.147 GB
Metadata Space Available: 2.141 GB
Udev Sync Supported: true
Deferred Removal Enabled: false
Data loop file: /var/lib/docker/devicemapper/devicemapper/data
Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
Library Version: 1.02.93-RHEL7 (2015-01-28)
Execution Driver: native-0.2
Logging Driver: json-file
Kernel Version: 3.10.0-229.7.2.el7.x86_64
Operating System: Red Hat Enterprise Linux
CPUs: 1
Total Memory: 3.703 GiB

#> df -i
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/sda3 47184896 372246 46812650 1% /
devtmpfs 483090 327 482763 1% /dev
tmpfs 485391 1 485390 1% /dev/shm
tmpfs 485391 530 484861 1% /run
tmpfs 485391 13 485378 1% /sys/fs/cgroup
/dev/sda1 65536 360 65176 1% /boot
isilon:/ifs/scratchy1_vol0/scratch/ps/djap 8375186224 6542158928 1833027296 79% /lan/dscratch/djap
sjclapa03-s2:/vols/stor_home13/djap 31876689 8322147 23554542 27% /home/djap
sjsnap01b:/vol/pkgs/RHEL7.0-2015-x86_64 10895354 4782218 6113136 44% /grid/common/pkgs


(Sam Saffron) #2

hmmm you sure you got enough disk space?


(Zenwanger) #3

@sam, I have 970G available to me on the disk I am using.


(Sam Saffron) #4

Can you try a different storage driver? aufs or overlay?


(Zenwanger) #5

Probably not aufs, but here is another update. All three scenarios fail with the same issue. Is the devicemapper driver not recommended or known to have this issue?

RHEL 7.1 w/ docker supplied docker image: Failed with same error (same storage driver)
RHEL 7.1 w/ redhat supplied package: Failed with same error (same storage driver)
SLES 12 : Failed with same error (same storage driver)


(Sam Saffron) #6

My understanding is device mapper is only recommended if your docker binary was dynamically compiled

You could try overlay, I have had lots of luck with it. anecdotally for me btrfs has been a bit flaky, but most likely due to older btrfs versions. aufs has been very solid.