Docker Community Forums

Share and learn in the Docker community.

Unable to run docker in Interactive mode


(Mohtashims) #1

I was trying to run docker in interactive mode where i could login to the container.

I switched to root user then I pulled the image using: docker pull jenkinsci/blueocean
This was successful.

I then tried running this image container in interactive mode using:

docker run -ti -p 8080:8080 -p 50000:50000 -v /tmp:/tmp jenkins

This starts the jenkins container but does not give me the containers prompt / shell

These are the last lines that i see as output and this is where it stays:

INFO: Obtained the updated data file for hudson.tools.JDKInstaller

Oct 12, 2018 3:52:58 AM hudson.model.AsyncPeriodicWork$1 run

INFO: Finished Download metadata. 4,930 ms

–> setting agent port for jnlp

–> setting agent port for jnlp… done

Here is my docker version:

docker version
 
Client:
 
Version:         1.12.6
 
API version:     1.24
 
Package version: docker-1.12.6-71.git3e8e77d.el7.x86_64
 
Go version:      go1.8.3
 
Git commit:      3e8e77d/1.12.6
 
Built:           Wed Dec 13 12:18:58 2017
 
OS/Arch:         linux/amd64
 
Server:
 
Version:         1.12.6
 
API version:     1.24
 
Package version: docker-1.12.6-71.git3e8e77d.el7.x86_64
 
Go version:      go1.8.3
 
Git commit:      3e8e77d/1.12.6
 
Built:           Wed Dec 13 12:18:58 2017
 
OS/Arch:         linux/amd64
 
[]# docker --version
 
Docker version 1.12.6, build 3e8e77d/1.12.6

Can you please suggest how can i get into the docker container’s prompt ?

Note: I m setting up docker container on Linux Virtual Cloud based server.


(Paulxroot) #2

Hi,

you could give it a try with first starting a shell in interactive mode and then start jenkins when you’re attached to the shell like this:

`docker run -ti -p 8080:8080 -p 50000:50000 -v /tmp:/tmp bash
then when your’re attached to the bash inside the container call the jenkins command.

Hope this helps.


(Mohtashims) #3

Thank you. The suggestion works.