Docker Community Forums

Share and learn in the Docker community.

Unable to specify docker daemon dns-search option

docker
dns
beta

(Dbrophy) #1

Expected behavior

During docker build, bare domains should resolve correctly using the dns-search options.

Actual behavior

Can’t specify dns-search option on the docker daemon, so debian mirror specified as a bare domain fails to resolve.

Information

  • the output of:
    • pinata diagnose -u on OSX

$ pinata diagnose -u
OS X: version 10.11.2 (build: 15C50)
Docker.app: version v1.11.1-beta10
Running diagnostic tests:
[OK] docker-cli
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x
Docker logs are being collected into /tmp/20160505-143935.tar.gz
Most specific failure is: No error was detected
Your unique id is: 05EF7276-88B1-46AD-8F13-0A068CFE4C2E
Please quote this in all correspondence.

  • a reproducible case if this is a bug, Dockerfiles FTW
  • page URL if this is a docs issue or the name of a man page
  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )

Steps to reproduce the behavior

Our internal debian mirror is referred to as “debmirror”. The dns-search option is needed to resolve the correct debmirror.company.net domain. With boot2docker, I was able to configure this with:

EXTRA_ARGS="–dns-search spotify.net"

… it seems pinata isn’t currently capable of setting this up.


(Dbrophy) #2

So I solved the problem. The pinata tool allows you to configure the daemon. Here’s the config options: https://docs.docker.com/engine/reference/commandline/daemon/#daemon-configuration-file

You can get your current config options like this:

$ pinata get daemon > myconfig.json

… make changes (in this case, adding “dns-search”: [“company.net”]), and upload the config to pinata with:

$ pinata set daemon @myconfig.json


Adding advanced features to the docker Daemon on mac