Docker Community Forums

Share and learn in the Docker community.

Unable to view Docker Desktop Settings in Windows 10

Hello, I have installed Docker Desktop (2.1.0.5) in Windows 10. Unfortunately, I am unable to view the Settings when I right click on Whale icon in System Tray.

Earlier I had faced the same issue but after couple of uninstall /re-install and couple of restart it had worked.
Other thing what I had observed is that if Enable Windows Container during installation, I can view the Settings but when I switch to Linux Containers, Right click on Whale Icon do not open up Settings.
But I can execute Docker related commands.

Can you please suggest.

Thanks in advance.

2 Likes

hey,

I have exactly the same prolem, and so far I’ve tried every single solution named in this github thread, but still no success.

I also downgraded my docker’s version but still nothing. It would be great if someone from the docker hub can answer.

Regards

To view Docker for Windows latest log , click on the Diagnose & Feedback menu entry in the systray and then on the Log file link. You can see the full history of logs in your AppData\Local folder.


Lewis

The problem with lewish95’s approach is the fact that there is no menu in the systray, as the OP stated. That is the same situation I’m in. Clicking the white whale does nothing, no response of any kind. The docker service is running, I can perform normal operations from the command line, but the GUI is not accessible because the only way to access it is from the unresponsive tray icon. The hover message is “Docker Desktop is starting…” and it’s been hung there this time for half an hour.

Docker Desktop 2.1.0.4 (39773), on Windows 10 Enterprise 1709

1 Like