Docker Community Forums

Share and learn in the Docker community.

Unexpected EOF error while building and login

Hi all,

that’s probably the first time in my life, that nobody else had the same issue :slight_smile:

While building a small app in GO i am getting all the time following errors:
=> ERROR [internal] load metadata for docker.io/library/golang:1.16-alpine
error: failed to solve: failed to solve with frontend dockerfile.v0: failed to create LLB definition: failed to do request: Head “https://registry-1.docker.io/v2/library/golang/manifests/1.16-alpine”: unexpected EOF

I guess this might be the same issue, which I get while doing the “docler login”:
Error response from daemon: Get “same v2 API” : unexpected EOF

I have an old MacBook Pro from 2014.

Absolutely the same issue happends if I try other images e.g. python.

Will appreciate any help, since I haven’t found any info in google for my issue.

Mmmmmm… Such a nice support! So wow

First of all, I am sorry you didn’t get an answer. I saw your question, but didn’t have time at the moment and then it seems I lost this topic twice.

Actually, this is not really a support. At least not a paid one. We as a community help eachother if and when we can. If we don’t know the answer while we see other questions, we answer those so your topic remains unanswered which is more noticable for people searching for new questions. It does not always work that way but this is how I see it.

In a case like this sharing additional details like links, github issues (there are some), keywords that you tried to search for can capture the users’ attention again. Commenting without any new detail can also do it but with less success and your topic will not be “unanswered” anymore.

If you still have this issue I can try to help. What is the version of your Docker Desktop? Recently I tried “hub-tool” again after some months but it didn’t work: cannot login: Error: failed to authenticate: bad status code "400 Bad Request": malformed request: EOF · Issue #191 · docker/hub-tool · GitHub

I had to upgrade it. If something changed on the server side and your client is too old it may cause a login error like this.