Docker Community Forums

Share and learn in the Docker community.

Update (5465) from previous (5193) keeps failing


(Pitaki) #1

Expected behavior

Process should stop running Docker and install new version and start it

Actual behavior

Process fails to shut down previous Docker and it ends with “red whale”

Information

  • the output of:

    • Moby Notification > Diagose & Feedback on Windows
      A diagnostic was uploaded with id: 9B3DBE94-F1F1-4E08-8C17-C05E09E58B1A/2016-07-19_11-33-41
  • a reproducible case if this is a bug, Dockerfiles FTW

  • page URL if this is a docs issue or the name of a man page

  • host distribution and version ( OSX 10.10.x, OSX 10.11.x, Windows, etc )

host: Windows 10 Pro (1511) build 10586.494
Processor Inter Core i3 64-bit

After first attempt of this update, the Docker does not start normally even if one
decides to press “Remind me Later” -button. System seems to stay hanging
on that update dialogue.

Steps to reproduce the behavior

  1. …Start Docker
  2. …Wait for Update -dialog to pop-up
  3. …Select one of the choices

(Pitaki) #2

Mystery solved</h1

Apparently reset to factory settings before attempting to update did the trick. After I managed to do that, I added some RAM for Docker to use and after that the update to 5465 went just fine

Sorry about the fuzz. I should have tried this reset before posting. Mea culpa!