What is happening here? What is prompt taking time for?

May I ask why you think the screenshot tells anyone anything?

Please provide context information, so we can understand how you started the container (as in exact docker run command or if docker compose was used: the compose file content), what you expect to happen and how you tried to verify your expectation.

I ran nginx:latest for experiment and learning purposes…
Now, I want to know what’s going on?
After starting worker process 36, why is cursor blinking and terminal doesn’t prompt up?

I forget to mention it in my first response, but please do NOT share text content as screenshots. It makes it unnecessarily harder to read, can not be indexed by the search, and we can not quote parts from it in a response. Instead, copy the text content, and add three backticks in the line before and after the content, so it gets properly formatted: ```

The image you picked, starts a container that runs nginx in the foreground, of course there will be no terminal.

If you are new to learning docker, I can highly recommend this free self-paced training: https://container.training/intro-selfpaced.yml.html. It will provide a solid understanding of docker concepts and how things are actually done in docker.

I will take care of that here on. And definitely i will pursue training. Thank you!


Note: the three backticks are only needed, if you post formatted content where we need to retain the format like when you copy/paste the content of terminal output, or when you share the content of a compose file or Dockerfile.