Docker Community Forums

Share and learn in the Docker community.

When is 'VPN Compatibility Mode' going to be enabled (Docker for Windows)?


(Carlosvin) #1

Expected behavior

  • Docker for Windows has VPN Compatibility Mode

Actual behavior

  • I can’t enable VPN Compatibility Mode

Information

I guess this feature is disabled in Docker for Windows, but do you know when it is going to be enabled?

Steps to reproduce the behavior

  1. Go to system tray
  2. Right click on docker
  3. Click on Settings
  4. VPN compatibility mode is disabled

(Rolf Neugebauer) #2

Hi @carlosvin

we started working on implementing the equivalent of VPN compat mode on Windows similar to what we offer on Mac. The networking setup on Windows is considerably different to the Mac, though, so it will take us some time to provide it. Do you have any specific issue with VPN?

Thanks
Rolf


(Carlosvin) #3

Good to know you are already working on it.

The issue is I don’t have connectivity to VPN hosts that used to be resolved when I am connected to the VPN.

I solved this issue before when I had docker toolbox configuring docker-machine doing something like this:
docker-machine create --driver virtualbox --virtualbox-host-dns-resolver=true --virtualbox-dns-proxy=true default

Now I don’t know how to do it with “native” docker for windows.

My hope was VPN compatibility mode solves this problem.


(Streetmapp) #4

As another use case, I can’t use Docker for Windows when I’m on my VPN. I run into the VM unable to get an IP so it fails after 60 attempts. However it works just fine when I’m in the office. So I too am hoping that VPN compatibility mode will help here.


(Jeffpek) #5

I also have this issue with VPN. Apparently the DockerNAT connection is blocked.

PS D:> docker images
Error response from daemon: dial tcp 10.0.75.2:2375: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.


(Streetmapp) #6

So today I’m again working remote using my VPN. This time it appears that Docker beat out my VPN from connecting so it actually started up and my VPN was connected. However, I then was having issues with my VPN and couldn’t resolve those until stopping Docker.


(David J. M. Karlsen) #7

Same here. Problem as the VPN software tries to hijack routes and not allow split tunneling. Works as a charm on Mac - however most of my colleagues are stuck on Windows - and this is our main hurdle to move the majority to docker.


(Cbrevik) #8

I also have problems with using VPN on my host machine, for two things really:

  • Contacting Docker Hub to pull down any images fails.
  • When trying to navigate to external sites from a Chrome instance when inside of a container. Might be related to my problem with cookies.

(Djbc3tech) #9

FWIW I show VPN Compatibility mode available, but it doesn’t solve my issues with Cisco VPN. Still no connectivity from my containers.


(Rolf Neugebauer) #10

It seems there might have been an issue with how packets are routed when VPN mode was enabled in Beta13. This should be fixed in Beta14 (released today) which also enables VPN mode by default. It would be great if you could give that a try and report back.
Thanks
Rolf


(Casablanca) #11

When the Docker is running only way that I can use VPN(openvpn) is that I have to disable vEthernet(DockerNAT) adapter and enable it after the VPN connection. This seems to be working without any problems.

But when I try to use VPN while the Docker is running and the adapter is enabled, openvpn gui starts using 30-40% CPU and I get zero connectivity to internet.

By the way, it’s not directly related but I can’t tracert while Hyper-V is on. I didn’t understand why it was happening for few days. But it was fixed when I disabled hyper-v and I couldn’t tracert again when I enabled Hyper-V again.


(Rolf Neugebauer) #12

Hi @casablanca

Thanks for the feedback and description.

In the next Beta, the NAT switch will be gone completely (replaced with a simple switch) and VPN mode will be the only means of networking. Hopefully that will fix your issues.

tracert works fine for more for www.google.com, but I’m on a RC for Beta15

Rolf


(David J. M. Karlsen) #13

Still not working for me with 1.12


(Riussi) #14

I’m having the same problems with F-Secure Freedome on Win10


(Meedeldock) #15

For me it is working fine. We are using Cisco AnyConnect software