Docker Community Forums

Share and learn in the Docker community.

Wifi Adapter Disabled When Hyper-V Network Adapter Enabled - Native

I just received a brand new work laptop and immediately installed the native version of Docker for Windows.

However I am seeing an issue that everytime the new network adapter for Docker via Hyper-V is enabled (vEthernet DockerNAT) then my Wifi Adapter is disabled and therefore I can not access the internet.

Whenever I try to enable the Wifi Adapter it keeps disabling itself immediately, the only way to get my internet back is by deactivating the DockerNAT HyperV Adapter.

This must surely work otherwise they wouldnt have released the Windows Native version publically?

Has anyone experienced this issue and know how to fix it? (This is my first experience with Hyper-V)

Was this resolved? I’m having the exact same issue.

I have the same problem. any news on this?

A workaround that was reported was to set the DockerNAT virtual switch connection type setup by the installation to Private and the wi-fi connectivity should work again. A more permanent solution is currently being investigated internally within Docker.

workaround worked for me, but every time i restart docker i have to set the virtual switch to this connection type…

I have the same problem installing Docker in a Windows 10 machine. I have tried a few work workarounds and cannot make the Wifi work again.

I changed the subnet address on docker settings to match my wifi ipv4 address and it worked for me.

After trying all types of remedies advised on internet, and with neither of them fixing the issue, I eventually found that in my case it was 3rd party software (PulseSecure) that was disabling WiFi whenever Hyper-V adapter was active. So, if you have this software installed as well there is a fat chance that it is causing the problem.
You can disable “Pulse Secure Service” service to see if that’s indeed the case, and if that solves your issue.

2 Likes

Thanks to @zqna now I’m going well with my WiFi up and running and Docker too.
I need to use PulseSecure to connect at some offices of my company, so I stopped the service and also changed its start policy to “Manual”.

Thanks for the good ideas to bring it. I know a lot more. เว็ปแทงบอล :slight_smile: :J

Unfortunately as of May 2019 the problem is still there, none of the solutions worked.

Interestingly, I did not have this problem on another Windows 10 laptop.

Me too
MSI GS60, Win 10 Home
I installed hyper v and edited registry to enable Docker Desktop to install yesterday as per Installing Docker on Windows 10 Home

Today the wi-fi adapter (Killer Wireless-n/a/ac 1525 stays enabled but 2 or 3 times shows “No Wi-Fi Networks found” but connects normally after reboot and stays online for a few hours before repeating. Drivers are updated. Disabling and re-enablong does not help. I don’t have PulseSecure but I will try to find out if any other software may be interfering on my machine. I will also try these workarounds now…

Hi all,
Do we have a permanent fix for this? I have to make it working with pulse secure as we use this to connect to client VPN and then run docker to perform other tasks. I tried changing the subnet address but it didn’t work.

Hello,
Did anyone find a solution to this? I m having the same issue with pulse secure and hyper v

Hi , for this problem using Pulse Secure software , i finded a update software by Pulse Secure solving the problem
see link
https://kb.pulsesecure.net/articles/Pulse_Secure_Article/KB43628