Docker Community Forums

Share and learn in the Docker community.

Windows 7 "This node is not a swarm manager" on docker stack deploy


(Tom8384) #1

Docker version: 1.13.1
Docker toolbox: 1.13.1a
Windows 7

After installing docker toolbox on windows 7 and using docker machine to create a swarm master and nodes, I am then not able to deploy.

Here are the steps - the following all work fine:

$ docker-machine create --driver virtualbox --swarm-image "swarm:latest" --swarm-master swarm-master
$ docker-machine create --driver virtualbox --swarm-image "swarm:latest" --swarm swarm-worker1
$ docker-machine create --driver virtualbox --swarm-image "swarm:latest" --swarm swarm-worker2

and I can ssh to the vms ok.

However, when I try and deploy the stack, docker complains…

$ eval $(docker-machine env swarm-master)
$ docker stack deploy --compose-file docker-stack.yml vote
time="2017-02-15T19:16:55Z" level=info msg="Unable to use system certificate pool: crypto/x509: system root pool is not available on Windows"
This node is not a swarm manager. Use "docker swarm init" or "docker swarm join" to connect this node to swarm and try again.

I’ve tried turning on debug logging and using --tlsverify, -H, --tlscert explicitly, but no joy either. Any clues as to what is wrong here? Thanks


(Tom8384) #2

After going back and RTFM, I missed the obvious step of initialising the swarm manager and joining each worker node to the swarm. Doing this and all worked fine.

That begs the question - can the swarm be initialised and nodes added WITHOUT having to ssh into each machine?


(Ralph Kincade) #3

I dont thinkg so ,not that I know of