Windows Container Build and Run Failed

Hi, I am new for Docker Windows Container, Recently, I’ve setup my Docket Desktop for windows container.

What issue I encounter is:
I can pull mcr.microsoft.com/windows/nanoserver:ltsc2019 or mcr.microsoft.com//windows/servercore:ltsc2019, but when I use below command to run container:

*docker run -it --rm mcr.microsoft.com/windows/nanoserver:ltsc2019 powershell*

I will get below error:

docker: Error response from daemon: hcs::CreateComputeSystem 0aca66fa16254c296648ed93b1e7bd1c6acc6a586495c39b8d2e6a59e2e310e8: The host compute system service has disconnected unexpectedly.

Besides, when I created a Dockerfile and use some command such as:

SHELL ["powershell", "-Command", "$ErrorActionPreference = 'Stop'; $ProgressPreference = 'SilentlyContinue';"]

RUN Get-ChildItem -Force C:\app

The step for RUN always throw same error of

hcs::CreateComputeSystem 00f48093fca79960f1a14236ed08a514551ca63eac43a83a13a0752209e08f52: The host compute system service has disconnected unexpectedly.

My Host machine as below.

Edition: Windows 10 Enterprise
System Type: 64-bit operating system, x64-based processor

Docker Info:

Client:
 Version:    24.0.7
 Context:    default
 Debug Mode: false
 Plugins:
  buildx: Docker Buildx (Docker Inc.)
    Version:  v0.12.0-desktop.2
    Path:     C:\Program Files\Docker\cli-plugins\docker-buildx.exe
  compose: Docker Compose (Docker Inc.)
    Version:  v2.23.3-desktop.2
    Path:     C:\Program Files\Docker\cli-plugins\docker-compose.exe
  dev: Docker Dev Environments (Docker Inc.)
    Version:  v0.1.0
    Path:     C:\Program Files\Docker\cli-plugins\docker-dev.exe
  extension: Manages Docker extensions (Docker Inc.)
    Version:  v0.2.21
    Path:     C:\Program Files\Docker\cli-plugins\docker-extension.exe
  feedback: Provide feedback, right in your terminal! (Docker Inc.)
    Version:  0.1
    Path:     C:\Program Files\Docker\cli-plugins\docker-feedback.exe
  init: Creates Docker-related starter files for your project (Docker Inc.)
    Version:  v0.1.0-beta.10
    Path:     C:\Program Files\Docker\cli-plugins\docker-init.exe
  sbom: View the packaged-based Software Bill Of Materials (SBOM) for an image (Anchore Inc.)
    Version:  0.6.0
    Path:     C:\Program Files\Docker\cli-plugins\docker-sbom.exe
  scan: Docker Scan (Docker Inc.)
    Version:  v0.26.0
    Path:     C:\Program Files\Docker\cli-plugins\docker-scan.exe
  scout: Docker Scout (Docker Inc.)
    Version:  v1.2.0
    Path:     C:\Program Files\Docker\cli-plugins\docker-scout.exe

Server:
 Containers: 0
  Running: 0
  Paused: 0
  Stopped: 0
 Images: 2
 Server Version: 24.0.7
 Storage Driver: windowsfilter
  Windows:
 Logging Driver: json-file
 Plugins:
  Volume: local
  Network: ics internal l2bridge l2tunnel nat null overlay private transparent
  Log: awslogs etwlogs fluentd gcplogs gelf json-file local logentries splunk syslog
 Swarm: inactive
 Default Isolation: hyperv
 Kernel Version: 10.0 19045 (19041.1.amd64fre.vb_release.191206-1406)
 Operating System: Microsoft Windows Version 22H2 (OS Build 19045.3803)
 OSType: windows
 Architecture: x86_64
 CPUs: 8
 Total Memory: 31.78GiB
 Name: TERRENCECHEN
 ID: 809b264e-5f7c-42d1-ada7-79eac71de839
 Docker Root Dir: C:\ProgramData\Docker
 Debug Mode: true
  File Descriptors: -1
  Goroutines: 45
  System Time: 2023-12-25T13:55:24.536434+08:00
  EventsListeners: 3
 HTTP Proxy: http://127.0.0.1:51214
 HTTPS Proxy: http://127.0.0.1:51214
 No Proxy: .mycompany.com
 Experimental: false
 Insecure Registries:
  docker-registry-default.xxx.mycompany.com
  127.0.0.0/8
 Live Restore Enabled: false
 Product License: Community Engine

is there anyone experimented or know how to resolve this error?
Many Thanks