Docker Community Forums

Share and learn in the Docker community.

Windows docker date wrong

Issue type : clock wrong

OS Version/build : Windows 10 Home Single Language 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406)

App version : docker info ( https://paste.ubuntu.com/p/W5Nv3DCHms/ ) / Docker Engine v19.03.13 /

Steps to reproduce

time|690x388

How do I solve the date problem?

I want it to be the same as the computer time

I live in Turkey :slight_smile:

I’m not sure if I understand your question correctly, but the clock in Docker containers is set to UTC. If you want them to use a different time you have to change their timezone settings.
This is from one of my images that I switch to time zone Zurich (modules not related to time zone deleted from the list):

RUN set -ex \
  && export DEBIAN_FRONTEND=noninteractive \
  && export DEBCONF_NONINTERACTIVE_SEEN=true \
  && echo 'tzdata tzdata/Areas select Europe' | debconf-set-selections \
  && echo 'tzdata tzdata/Zones/Europe select Zurich' | debconf-set-selections \
  && apt-get update \
  && apt-get install -y --no-install-recommends \
    tzdata \
  && rm -rf /var/lib/apt/lists/*

Show us how you create your images and how you start your containers. It is not possible to give a general answer if we don’t know what you are doing.