Docker Community Forums

Share and learn in the Docker community.

WSL Not Installing / Docker Failed to Start

Issue Type: WSL Not Installing / Docker Failed to Start
OS Version/Build: Windows 10 - 10.0.19044 Build 19044
System Model: Veriton M480G
System Type: x64-based PC
Processor: Intel(R) Core™2 Quad CPU Q8400 @ 2.66GHz, 2670 Mhz, 4 Core(s), 4 Logical Processor(s)
App Version: Docker Desktop
Version: 4.4.3
BIOS Version/Date: Acer P01-A3, 8/7/2009
SMBIOS Version: 2.6
Installed Physical Memory (RAM): 8.00 GB
Hyper-V - Virtualization Enabled in Firmware: Yes
Hyper-V - Data Execution Protection: Yes

Docker will not run. I’ve gotten docker up and running on other machines. This one is a tad older and doesn’t want to want to cooperate. I’ve enabled virtualization in the BIOS as directed by the error message that pops up. I also have enabled:
Hyper-V
Virtual Machine Platform
Windows Hypervisor Platform
Windows Subsystem for Linux

I’ve noticed when I run the power shell command “wsl -l -v
Windows Subsystem for Linux has no installed distributions.” message pops up. Where as on the other machines that work they will say what distribution they are running. I’m thinking it has something to do with WSL not installing. I’ve tried to disable/reboot/enable/reboot technique and that didn’t do anything.

Any help appreciated,

Thanks!