Docker Community Forums

Share and learn in the Docker community.

WSL2 running out of volume space

I am running a docker container that is syncing the whole btc blockchain (380GB). I am using a volume for that, so that restarting the container does not require to sync it all again. However, I run into a problem that my container is running out of disk space.

Filesystem Size Used Avail Use% Mounted on
overlay 251G 64G 175G 27% /
tmpfs 64M 0 64M 0% /dev
tmpfs 6.3G 0 6.3G 0% /sys/fs/cgroup
shm 64M 0 64M 0% /dev/shm
/dev/sdc 251G 64G 175G 27% /etc/hosts
overlay 6.3G 6.3G 0 100% /root/bitcoin-node/data
tmpfs 6.3G 0 6.3G 0% /proc/acpi
tmpfs 6.3G 0 6.3G 0% /sys/firmware

I have been googling/trying/reading about this for several days now, but I was not able to increment the volume space. Many comments on this matter are outdated and pre-wsl2. Hyper-V manager for example does not show a virual machine because WSL2 is used.

After starting my container this line goes to 100% within a few minutes:
overlay 6.3G 6.3G 0 100% /root/bitcoin-node/data
Only 6.3G available…

Maybe running all kind of prune commands would give me a bit more, but the whole chain will be about 380G. So no matter the prune command, I will run out of space sooner or later if I do not manage to increment the available space for volumes. My disk has more then enough space available!

So my question: How to increment the space available for volumes on WSL2?

I also tried to map the volume directly to my windows e:-drive with:
-v /mnt/e/bitcore-data/livenet:/root/bitcoin-node/data
By using /mnt a performance drop should be expected according the things I read. But I do not see any data getting in via Windows Explorer… and df -h gives me exactly the same picture (overlay going to 6.3G (100%) in a few minutes) So as an alternative solution to my problem, this is also failing for unknown reasons.

I did notive many people experience similar issues on different forums. So hopefully someone can make end to this problem. Thank you for helping me!