No space in Docker container on WSL2


I am running WSL2 and Docker desktop. running Ubuntu 20.04 on a Docker container, I seem to have run out of space and can no longer copy files.

Problem/error message being encountered.

cp: error writing '. /idx000000001_00000001_spk00000001_Aka_Female1_ir[H242_1]_noise00000001_CROWD_HALL_SN_-0dB_Mix.wav': No space left on device

What I tried

I ran the df command and got the following.

Filesystem Size Used Avail Use% Mounted on
overlay 251G 251G 0 100% /
tmpfs 64M 0 64M 0% /dev
tmpfs 32G 0 32G 0% /sys/fs/cgroup
shm 8.0G 352K 8.0G 1% /dev/shm
/dev/sdb 251G 31G 209G 13% /mnt
tmpfs 32G 0 32G 0% /mnt/wsl
/dev/sdd 251G 251G 0 100% /mnt/wsl/docker-desktop-data/isocache
none 32G 16K 32G 1% /mnt/wsl/docker-desktop/shared-sockets/host-services
/dev/sdc 251G 120M 239G 1% /mnt/wsl/docker-desktop/docker-desktop-user-distro
/dev/loop0 476M 476M 0 100% /mnt/wsl/docker-desktop/cli-tools
C:\ 953G 315G 639G 34% /mnt/c
D:\ 932G 323G 610G 35% /mnt/d
F:\ 3.7T 380G 3.3T 11% /mnt/f
drivers 953G 315G 639G 34% /usr/bin/nvidia-smi
lib 953G 315G 639G 34% /usr/lib/x86_64-linux-gnu/
none 32G 0 32G 0% /dev/dxg
tmpfs 32G 0 32G 0% /proc/acpi
tmpfs 32G 0 32G 0% /sys/firmware

I also moved the WSL2 and Docker entities (vhdx files) to another drive where there is more room. The drive itself is 4TB and still has over 3TB to spare.

Can you please tell me how to solve the space?