Docker Community Forums

Share and learn in the Docker community.

X509: certificate signed by unknown authority Ubuntu Server behind proxy

I’m running in a server with ubuntuserver 16 with docker installed.I’m working behind a corporate proxy, which has internet connection because I can log in in the docker hub.
When I execute sudo docker run hello-world the following error appears:

latest: Pulling from library/hello-world
ca4f61b1923c: Pulling fs layer
docker: error pulling image configuration: Get https://dseasb33srnrn.cloudfront.net/registry-v2/docker/registry/v2/blobs/sha256/f2/f2a91732366c0332ccd7afd2a5c4ff2b9af81f549370f7a19acd460f87686bc7/data?Expires=1523312327&Signature=NRKvCXmfbeNeq7bq6E5doFrBElhIs9B8Dne-fLv10DpRoNXfzK45TATY39ZbIb0H9ijE3WDjxbPO8hfw7tnAcGWnfZBlwoiGCUlUAOy7d5m8B6qTcksmWsrDU5YvIUoFYjEk5wB~t0sbZfChWFiLINQWTLuBv1nnEECSm5zH9qc_&Key-Pair-Id=APKAJECH5M7VWIS5YZ6Q: x509: certificate signed by unknown authority.

Solutions tried:
I tried to copy the ca-certificate.crt from /etc/ssl/certs/ to /usr/local/share/ca-certificates/ and restarting docker but the error appeared again.

Any idea why this happens?

Thank you in advance,

I have similar issues with the hello-world. I made an account for docker-dot-com, because I read it might help to make a docker login before running the example.
But it will also not let me login with that error saying:
Error response from daemon: Get https://registry-1.docker.io/v2/: x509: certificate signed by unknown authority

I work with Docker version 19.03.2, build 6a30dfc
and Ubuntu 18.04.3 LTS

Its a fresh installation which I just installed using my Internetconnection in that VM, which also works.
Further I read in some Thread here, that there is no more docker dot io - it now should be docker dot com.

running the example:
docker run hello-world
Unable to find image ‘hello-world:latest’ locally
docker: Error response from daemon: Get https://registry-1.docker.io/v2/: x509: certificate signed by unknown authority.
See ‘docker run --help’.

when running the example it also tries to get through to docker-dot-io.
I guess we need to change that url somewhere before we can get started.

I hope somebody here could help. I do not know which certificate fails nor do I know anything about certificates. Just want to start building containers - no security needed.

An other interesting thing is - If I try go on the page with the registry-1-url above, I get a JSON saying:
{“errors”:[{“code”:“UNAUTHORIZED”,“message”:“authentication required”,“detail”:null}]}

I guess this also could not be what we need here. (just an idea)

I could solve the issue by using a hotspot on my mobile phone. If there is no proxy I guess it works just fine.
Alltough the JSON I get by the address above still shows the same
{“errors”:[{“code”:“UNAUTHORIZED”,“message”:“authentication required”,“detail”:null}]}
.