X509: certificate signed by unknown authority in Windows using Docker Toolbox

Expected behavior

Able to download images from docker hub

Actual behavior

I am totally new to docker. Trying out my own from the tutorials available online.
I tried installing docker @ my home laptop and it works fine. I am able to download images.

But currently working in office network behind a corp proxy. Have set all other environment variables including no_proxy,http_proxy,https_proxy

Still getting the below error

$ ./docker pull mongo
Using default tag: latest
latest: Pulling from library/mongo
5c68a10e9f3f: Pulling fs layer
0110f95fa9c8: Pulling fs layer
0cba4a42bc41: Pulling fs layer
a6eafd7fba3f: Waiting
703d9d7e0e21: Waiting
7a4b36461321: Waiting
5b3580f1488d: Waiting
913554e7fcc9: Waiting
2f9b4a452eb8: Waiting
error pulling image configuration: Get https://dseasb33srnrn.cloudfront.net/regi
stry-v2/docker/registry/v2/blobs/sha256/87/87bde25ffc6863b0d39aaac3310eb5d859134
87a72c3700df5f4e95584d2be42/data?Expires=1470122537&Signature=NaGuUYvT0vl4uAg7ko
R6HaRuFTZ84kwnwRtDmKtbiewBJyQqynUm26lDifDHlCm~ArRpWxN89KGQ87rHk8xj3nqdvZdIy5SoFl
XhfooPp6QKZRTJ5elYXQaMKSaYzTOUTS0Tz4cVNF579n4yFqOMosGulCA7ry0vbW9~n8bwtLE_&Key-P
air-Id=APKAJECH5M7VWIS5YZ6Q: x509: certificate signed by unknown authority

Information

MINGW64 /c/Program Files/Docker Toolbox
$ ./docker info
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 1.12.0
Storage Driver: aufs
Root Dir: /mnt/sda1/var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 0
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge null host overlay
Kernel Version: 4.4.16-boot2docker
Operating System: Boot2Docker 1.12.0 (TCL 7.2); HEAD : e030bab - Fri Jul 29 00:2
9:14 UTC 2016
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 995.9 MiB
Name: default
ID: KMBV:DXQ4:E5OB:RAOH:SVV5:2BFR:PN7J:NRZ5:NQR7:6VWI:AES5:23L6
Docker Root Dir: /mnt/sda1/var/lib/docker
Debug mode (client): false
Debug mode (server): true
File Descriptors: 14
Goroutines: 23
System Time: 2016-08-02T07:15:28.665618285Z
EventsListeners: 0
Http Proxy: proxy.abcd.com:6050
Https Proxy: proxy.abcd.com:6050
No Proxy: 192.168.99.101
Username: abcd1234
Labels:
provider=virtualbox

$ ./docker version
Client:
Version: 1.11.1
API version: 1.23
Go version: go1.5.4
Git commit: 5604cbe
Built: Tue Apr 26 23:44:17 2016
OS/Arch: windows/amd64

Server:
Version: 1.12.0
API version: 1.24
Go version: go1.6.3
Git commit: 8eab29e
Built: Thu Jul 28 23:54:00 2016
OS/Arch: linux/amd64

It will be of great help if someone can provide suggestions on this on how to fix this error. Thanks in Advance

Intermittently getting this error as well while trying to pull. have provided the proxy details in username:password@proxy.com:8080

$ ./docker pull mongo
Using default tag: latest
Pulling repository docker.io/library/mongo
Get https://registry-1.docker.io/v1/repositories/library/mongo/tags/latest: Proxy Authorization Required

You have 2 different versions of docker on the client and on the server. … Did you try to update Docker Toolbox?

seems that docker 1.12 is complaining about your registry ssl certificate being self signed.

I think I’m having the same issue in a different config. I’m running a private registry with a self signed certificate and things are running fine with hosts on 1.11 but my latest host on 1.12 is giving me the same “certificate signed by unknown authority” message at the first pull request.

there is this message in the doc https://docs.docker.com/registry/insecure/ that’s possibly related

Warning: using this along with basic authentication requires to also trust the certificate into the OS cert store for some versions of docker (see below)

Hey. Do you find a solution for your issue? I faced the same one.

I face similar problem with docker in Windows 7.

Sending build context to Docker daemon 2.048 kB
Step 1 : FROM alpine
Pulling repository docker.io/library/alpine
Error while pulling image: Get https://index.docker.io/v1/repositories/library/alpine/images: x509: certificate signed by unknown authority

Client:
Version: 1.12.6
API version: 1.24
Go version: go1.6.4
Git commit: 78d1802
Built: Wed Jan 11 00:23:16 2017
OS/Arch: windows/amd64

Server:
Version: 1.12.6
API version: 1.24
Go version: go1.6.4
Git commit: 78d1802
Built: Wed Jan 11 00:23:16 2017
OS/Arch: linux/amd64

Any pointers to fix this will be much appreciated. Thanks!

I have the issue too but I know what the issue is. I am sitting behind a proxy server that does SSL intercept - effectivelya man in the middle but not malicious. I work in a School District and SSL traffic has to be intercepted to control student browsing activities.

When doing normal browsing, the proxy server’s SSL certificate has to be installed in the browser or system Certificate Store as a Trusted Root CA. The question is how to do this for Docker Toolbox. Now I am guessing that the docker daemon that does the actual image downloading is running on the “default” virtual machine in VirtualBox and that I need to drop the certificate in there somewhere. Will reply again with progress.

Problem sorted.

http://stackoverflow.com/questions/31205438/docker-on-windows-boot2docker-certificate-signed-by-unknown-authority-error

I had a little trouble at first because I messed up conversion of the certificate format. Once I followed instructions to the letter it did the trick for me. Happy camper am I!

1 Like

@esquincle01 Your solution worked like a charm . Thank you