Docker Community Forums

Share and learn in the Docker community.

3 clicks to brick the system


(Mario Pietsch) #1

System: win10 pro. V 1607

How to reproduce:

  • right click docker4windows program icon
  • click activate “windows containers” dialog (to test the UI design)
    • windows container feature is not installed
    • and I don’t intend to install it.
  • answer the following dialog with NO
    • dialog text is:
Containers feature is not enabled.
Do you want to enable it for Docker to be able to work properly?
Your computer will restart automatically.

2 things happen:

a) MobyLinuxVM will be shut down, but the program doesn’t know, if it really should.
b) Docker shuts down and the user is unable to be restart d4w without installing additional software


Expected behaviour:

add a) The program should not assume that users always click the “yes” button. It should start action when the user decision is known.

add b) The program should revert to the old settings / state if the user clicks the “no” button. Clicking the NO button I meant: “I don’t want to activate new stuff, but I still want docker to work properly!”


At the moment docker4windows is bricked and I’m frustrated. As I wrote, I just wanted to see the new UI …

have a nice day!


Windows 10 container feature vs installing docker
(Michael Friis) #2

Sorry about the breakage, can you try running DockerCli.exe -SwitchDaemon from C:\Program Files\Docker\Docker\


(Mario Pietsch) #3

./DockerCli.exe -SwitchDaemon worked. … thx.

I found the file: daemonsocket in C:\ProgramData\Docker and deleted it. That also fixed the problem. Your command is probably the better choice.

… But there is still the issue, that the file is created immediately, which I consider an issue. See: add b)


(Mario Pietsch) #4

I did uninstall and install docker4windows, which also didn’t fix the problem. …

So it seems the uninstall procedure didn’t work either, since it should have cleared C:\ProgramData\Docker. right?


(Michael Friis) #5

We’re aware and are tracking a fix! Thanks for reporting.