Docker Community Forums

Share and learn in the Docker community.

All Docker Hub images failing (permissions)

I’ll apologise first as I’m very new to this but I’m desperate to get this working.

I have a Linux Mint machine I use to test images and that’s all fine. Images run fine.

I have an Ubuntu 20.x server freshly installed and it includes the default ‘Install Docker’ as part of the standard installation.

Docker is working in that the ‘Hello World’ Image runs fine and exits ok.

Almost every other image I’ve tried (inc drupal/Wordpress amongst others) for testing fails to run due to permissions issues. It seems the initial script each image tries to run fails with a permissions error.

I’ve spent hours googling this so apologies if this is obvious but I can’t seem to get any images to run on my Ubuntu server.

Hope there is enough info here and it’s a quick fix. I’m potentially going to reinstall Ubuntu without the option disabled and then installing via apt-get to use the package. I’m wondering if that might be the issue.

Thanks for any ideas.

If your using Docker-ce, always be “root”

… what permission problems do you get ? Error message ?

I typically get this:

/bin/bash: /app-entrypoint.sh: Permission denied

This happens on multiple different container images I’ve tried with slightly varying start scripts. I’m using ‘sudo’ when using the ‘Docker run xxx’ command and I’ve tried adding my user to the Docker group too to remove the need for sudo.

I don’t have this trouble on my other Docker instance on my desktop where sudo seems to work every time.

Thanks for the response.

Never mind. I reinstalled Ubuntu without the in built option to install docker and installed it after via ‘apt’ and it seems fine. Very odd.

All working now but thanks for the steer. I think you were in the right area so must be some odd default security settings for the norm. Perhaps it was hardened in some way and I’m not experienced enough to figure it out.

Thanks.

Please tell us rour “docker run …” cmd and content of the Dockerfile