Docker Community Forums

Share and learn in the Docker community.

Error Running Hello-World Image

I just installed Docker for Ubuntu 18.04 following the instructions found here. However, when attempting to run the hello-world image, I receive this error:

docker: Error response from daemon: OCI runtime create failed: container_linux.go:345: starting container process caused "process_linux.go:430: container init caused \"rootfs_linux.go:58: mounting \\\"proc\\\" to rootfs \\\"/var/lib/docker/overlay2/8bf159640ee882387f8a087ea7d089957209f97a9ff811534adb40fbc7190ca4/merged\\\" at \\\"/proc\\\" caused \\\"permission denied\\\"\"": unknown.
ERRO[0000] error waiting for container: context canceled 

When I run as sudo I get the same error. I have tried giving the user write permissions for all the directories mentioned in the error but it hasn’t solved anything. I’ve also uninstalled and reinstalled multiple times to make sure I’m following the instructions properly.

Here is the result from running ‘docker info’:

Client:
Debug Mode: false

Server:
  Containers: 13
  Running: 0
  Paused: 0
  Stopped: 13
 Images: 1
 Server Version: 19.03.0
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Native Overlay Diff: false
 Logging Driver: json-file
 Cgroup Driver: cgroupfs
 Plugins:
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc
 Default Runtime: runc
 Init Binary: docker-init
 containerd version: 894b81a4b802e4eb2a91d1ce216b8817763c29fb
 runc version: 425e105d5a03fabd737a126ad93d62a9eeede87f
 init version: fec3683
 Security Options:
  apparmor
  seccomp
   Profile: default
 Kernel Version: 4.15.0-47-generic
 Operating System: Ubuntu 18.04.2 LTS
 OSType: linux
 Architecture: x86_64
 CPUs: 112
 Total Memory: 2.922TiB
 Name: [OMITTED]
 ID: PHIU:5VG4:HDDR:KZ2F:D63P:TMRK:7GFO:HSCQ:2XOP:2EFM:2QKR:XTYX
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Registry: https://index.docker.io/v1/
 Labels:
 Experimental: false
 Insecure Registries:
  127.0.0.0/8
 Live Restore Enabled: false

WARNING: No swap limit support
WARNING: bridge-nf-call-iptables is disabled
WARNING: bridge-nf-call-ip6tables is disabled

Does anybody know what is causing this issue and how I can fix it? Thank you in advance for any help you can provide!