Docker Community Forums

Share and learn in the Docker community.

Authentication Error While Validating Invite Token


(Michael Schmidt) #1

When entering the invite token, right after the first start of Docker, I get the following error:

I’m running behind a corporate http proxy which is configured in the network settings. It is using an auto-discovery script.

I found the following log:

- Starting Watchdog 97805
2016-03-31T13:37:14.586140+02 Info - Authenticate with token: [] try 0
2016-03-31T13:37:14.586656+02 Error - ERROR while submitting token: ssh session failed to connect: Connection refused
2016-03-31T13:37:15.086888+02 Info - Authenticate with token: [] try 1
2016-03-31T13:37:15.114737+02 Error - ERROR while submitting token: Token required.
2016-03-31T13:37:26.179500+02 Info - text changed
2016-03-31T13:37:26.896847+02 Info - Entered token: redacted
2016-03-31T13:37:26.917219+02 Info - Authenticate with token: [redacted] try 0
2016-03-31T13:37:34.105848+02 Error - ERROR while submitting token: failed to connect to online service
2016-03-31T13:37:37.875489+02 Info - text changed
2016-03-31T13:37:38.580631+02 Info - Entered token: redacted
2016-03-31T13:37:38.584205+02 Info - Authenticate with token: [redacted] try 0
2016-03-31T13:38:54.035838+02 Error - ERROR while submitting token: failed to connect to online service
2016-03-31T13:39:04.630525+02 Info - Entered token:
2016-03-31T13:39:04.632204+02 Info - Authenticate with token: [] try 0
2016-03-31T13:39:04.632823+02 Error - ERROR while submitting token: Token required.
2016-03-31T13:39:10.431177+02 Info - text changed
2016-03-31T13:39:11.430287+02 Info - Entered token: redacted
2016-03-31T13:39:11.432375+02 Info - Authenticate with token: [redacted] try 0
2016-03-31T13:39:30.700986+02 Error - ERROR while submitting token: failed to connect to online service

This looks like this is trying to open a SSH connection to some outside server. In our coporate network this is not possible. Only HTTP(S) via Proxy is possible to the outside world.


(Michael Schmidt) #2


(Michael Schmidt) #3


(Frenchben) #4

Hi @bugroger we’ve made some changes to our token validation functionality so that it uses a more common port - Previous versions of Docker for Mac were sometimes blocked by a firewall / corp environment.

If you still experience the same issue, please ping us back


(Michael Schmidt) #5

Still similar trouble with beta6

2016-04-07T15:09:27.386267+02 Info - Application version: 1.11.0-beta6 (5404)
2016-04-07T15:09:27.407812+02 Info - OSX Version: Version 10.11.2 (Build 15C50)
2016-04-07T15:09:27.724189+02 Info - migrator: start migration process
2016-04-07T15:09:27.728570+02 Info - migrator: previous install detected
2016-04-07T15:09:27.728622+02 Info - migrator: previous version is 1.10.3-beta5
2016-04-07T15:09:27.728651+02 Info - migrator: 1 migrations to perform
2016-04-07T15:09:27.728678+02 Info - migrator: migrating for version 1.11.0-beta6 ...
2016-04-07T15:09:27.730074+02 Info - migrator: migration succeeded for version 1.11.0-beta6
2016-04-07T15:09:27.730118+02 Info - migrator: successfully updated from version 1.10.3-beta5 to 1.11.0-beta6
2016-04-07T15:09:27.730145+02 Info - migrator: end of migration process
2016-04-07T15:09:27.773800+02 Info - event tracker initialized
2016-04-07T15:09:27.775933+02 Info - Limited access: checking...
2016-04-07T15:09:27.857560+02 Info - Limited access: wrong certificate. Asking user for token
2016-04-07T15:09:29.770267+02 Info - text changed
2016-04-07T15:09:31.721842+02 Info - text changed
2016-04-07T15:09:36.647486+02 Info - text changed
2016-04-07T15:09:37.361765+02 Info - Entered token: redacted

(Michael Schmidt) #6

From the looks you are trying to phone home with SSH? In this environment the only possible connection to the outside world needs to go through a proxy server using HTTP(S).

If this is just the validation for the beta token, I can easily do so in a less restrictive network.


(Frenchben) #7

@bugroger that’s correct - it’s a simple validation of the Token.

The latest releases should make use of HTTPS instead of the more restricted ssh-like connection. If you can do it on a less restrictive network, it would work as well.


(Fabian Ruff) #8

Hmm, this still does not work for me. I’m behind the same corporate proxy and I also can’t submit my token. I just downloaded the docker app, so I’m assuming I’m using the latest version. If it should be using https then it does not seem to respect the system proxy settings.


(Jhiatt) #9

I just downloaded the latest version of Docker for Mac today and I am not able to submit my token as well.


(John Kaczmarek) #10

Same here. I’m on 1.11.0-beta8. I’ll try when I get home I guess.

Edit: It worked fine from my home network so it must be something at work.


(Jhiatt) #11

Just installed Version 1.11.1-beta11 (build: 6974) this morning and I was able to submit my token.
Everything is working great now.


(Pavelvanecek) #12

I just downloaded Docker for Mac from https://beta.docker.com/docs/ and I am not able to verify my invite token. I am behing a corporate proxy that is configured via remote autoproxy.pac file downloaded from intranet somewhere.

See the error on screenshot:

When I attempt to reach the URL via curl or browser (which I happen to know are configured properly to use a proxy) I am able to reach the server.

I don’t know which version it is but the Docker.dmg file that I downloaded says “last modified May 17”.


(Rerosum) #13

I have the same issue. Can someone please suggest a fix? Thanks


(Scheb) #14

Get Proxifier. It worked for me.


(Jhiatt) #15

This is how I got it to work.
Open Terminal, export proxy variables, the run “open /Applications/Docker.app/”