Docker Community Forums

Share and learn in the Docker community.

Can't validate invitation token behind proxy


(Dmitry Maslennikov) #1

While I’m not have a direct access to internet from my Windows 10 pro machine, only proxy, and validation does not work at all

[14:56:12.203][Program        ][Info   ] Version 1.11.1-beta10 (build: 2446)
[14:56:12.203][Program        ][Info   ] Starting on: 5/5/2016 2:56:12 PM
[14:56:12.203][Program        ][Info   ] Resources: C:\Program Files\Docker\Docker\Resources
[14:56:12.203][Program        ][Info   ] OS: Windows 10 Pro
[14:56:12.203][Program        ][Info   ] Edition: Professional
[14:56:12.203][Program        ][Info   ] Id: 1511
[14:56:12.203][Program        ][Info   ] Build: 10586
[14:56:12.203][Program        ][Info   ] BuildLabName: 10586.212.amd64fre.th2_release_sec.160328-1908
[14:56:12.203][Program        ][Info   ] Mixpanel Id: E90AC483-2004-4DAA-B9FF-E8AB1DD249A8
[14:56:12.203][Program        ][Info   ] Sha1: 51937ce6b9f8f70c9a642f493d63db1521a4fb7d
[14:56:12.203][Program        ][Info   ] You can send feedback, including this log file, at https://forums.docker.com/c/docker-for-windows
[14:56:12.312][Mixpanel       ][Info   ] Tracking: appLaunched
[14:56:12.609][Mixpanel       ][Info   ] Tracking: heartbeat
[14:56:12.875][BackendServer  ][Info   ] Started
[14:56:12.890][NamedPipeServer][Info   ] CheckInstallation:[]
[14:56:12.890][HyperV         ][Info   ] Check Hyper-V Windows optional feature
[14:56:12.890][PowerShell     ][Info   ] Run script...
[14:56:14.672][HyperV         ][Info   ] Hyper-V Windows feature is enabled
[14:56:14.672][NamedPipeServer][Info   ] CheckInstallation done.
[14:56:14.672][NamedPipeServer][Info   ] CheckHyperVState:[]
[14:56:14.672][HyperV         ][Info   ] Check Hyper-V Service State
[14:56:14.672][PowerShell     ][Info   ] Run script with parameters: -Check True...
[14:56:17.390][HyperV         ][Info   ] Hyper-V is running and responding
[14:56:17.390][HyperV         ][Info   ] Hyper-V is running
[14:56:17.390][NamedPipeServer][Info   ] CheckHyperVState done.
[14:56:17.422][Authentication ][Info   ] Checking token
[14:56:17.437][Mixpanel       ][Info   ] Tracking: installAskForToken
[14:56:52.974][Notifications  ][Error  ] Error: Put https://validate.docker.com/api: dial tcp 54.88.126.221:443: i/o timeout

[14:56:56.473][Program        ][Info   ] Sending Bugsnag report 0909f7b9-8179-4eab-8b18-7d4f4a4a4d66 ...
[14:56:58.654][Program        ][Info   ] Bugsnag report sent
[14:57:32.248][Mixpanel       ][Info   ] Tracking: installAskForToken

(T D) #2

Hi.

Have you set the proxy environmental variables? I had the same issue, and I set HTTP_PROXY and HTTPS_PROXY and it worked.


(Dmitry Maslennikov) #3

Thanks, and for others, variable should be filled in this format
HTTP_PROXY=192.168.0.1:8080


(Jrack) #4

For me I used our GTM address and needed both the HTTP and HTTPS variants with the URL structure http://hostname:port and https://hostname:port.


(Diteresa) #5

And where do I can set this HTTP_PROXY ??


(Dmitry Maslennikov) #6

As any others evnironment variables in windows


(Diteresa) #7

Oh yes thanks its logical :sweat_smile:


(Rterrero) #8

Perfect for me!!! Thanks!!!