Docker Community Forums

Share and learn in the Docker community.

Push failed on automated build

amazonwebservices
dockerhub

(Romainpodbox) #1

Hello,

I created an automated repo recently with a Dockerfile and README.md.
After several tries to build the images, I’ve got alternativly these errors:

Push failed: {"errorDetail":{"message":"Head 
https://dseasb33srnrn.cloudfront.net/registry-v2/***Key-Pair-Id=****:
dial tcp 54.230.195.162:443: i/o timeout"}}

Or:

Build process failed: Authentication is required.

I manage to build the image flawlessly in several local environment. Is there something I can do?


Automatic build runs into error
(Tiago Antao) #2

I am having the same problem. To see if my Dockerfile was to blame I have tried to trigger some old images (no change made) and the problem suddenly appeared on existing images that were fine.

Here is the log:

Cloning into ‘bkrwetmu768ytkpxtqsssyi’…
KernelVersion: 3.13.0-40-generic
Os: linux
BuildTime: Mon Oct 12 05:37:18 UTC 2015
ApiVersion: 1.20
Version: 1.8.3
GitCommit: f4bf5c7
Arch: amd64
GoVersion: go1.4.2
Step 0 : FROM biopython/biopython:latest
Authentication is required.


(Jan Boonen) #3

I’m having the same problem. It might be temporary problem. Hopefully Docker staff will look into this a.s.a.p.


(Osvaldo Matos-Junior) #4

+1
I’m using a public github repository.


(Andy Truong) #5

I have same issue on various reposes.


(100bitcrypt) #6

+1
It gets through the build successfully, but then fails on the push.


(Loansolutions) #7

I have same issue on current build.

54.230.192.145:443: i/o timeout"


(Dror) #8

+1
also gets through the build successfully, but then fails on the push.
no authentication errors though, only this:
"dial tcp {$IP}: i/o timeout"
consistent since yesterday.
serious ops blocker, please resolve this ASAP


(Loansolutions) #9

It gets through the build successfully, but then fails on the push.


(Phelim Bradley) #10

+1
Same problem here.


(Christophe Burki) #11

I have the same problem since yesterday evening. Failed with autobuild and manually triggered.


(Levi Smith) #12

+1 same issue for about 24hrs now as well.

Update: At least they are aware https://status.docker.com/


(Balázs Brankovics) #13

I had the same problem. Today I finally managed to solve it after struggling for more than a day. I think that the base of the build has to be linked: at Build settings add the docker image that is specified with FROM in the Dockerfile to the link docker repositories part. Than trigger a build. I hope this helps you guys as well!


(Jary) #14

+1 experiencing it as well


(Levi Smith) #15

@brankovics suggestion worked for me.

Linking the repo under “build settings” that I have in my “FROM” section of the dockerfile allowed my build to succeed finally! So @brankovics++


(Christophe Burki) #16

Thanks brankovics ! Build succeed after linking the repo under build settings.


(Allen Lai) #17

We are aware of the issue and our Engineers are working feverishly on a fix. We don’t have a timeline to share for the fix at this time. However, we recommend that you go to the Docker Status Page to get the latest update. You can subscribe to the incident and be automatically notified when an update is available.

We apologize for the inconvenience and thank you for your patience during this matter.


(Scott Miller) #18

I’m seeing All systems operational on the status page, but I’m still having this issue. I have a ticket open: https://support.docker.com/hc/en-us/requests/8667

edit: mine is being built and pushed from an external Jenkins, so not quite the same issue.