Docker Community Forums

Share and learn in the Docker community.

Bad response from docker engine

I’m on macbook pro 2018, running the latest OS and docker desktop 4.x.

I have some containers running, then I try to stop them and run docker-compose -f docker-compose-dev.yml down -v --remove-orphans (actually this is a make command that runs it along with a couple of others, but I don’t think it matters). One of about three times when I run this command I get Error response from daemon: Bad response from Docker engine and docker gets dead and I need to restart it to fix. The restart takes about 2 minutes after this error. I need to restart containers multiple times a day, so I face this issue every day for several times. And it annoys me quite a lot as I get distracted from work and need to wait until it restarts, and sometimes there’re two or three bad responses in a row.

There’s an issue on github about it Error response from daemon: Bad response from Docker engine · Issue #5283 · docker/for-mac · GitHub but it’s been around for almost a year and nothing’s happening there.

So my questions are: is it completely a problem with docker or is it me doing something silly? Does anyone know a way to avoid this problem except for downgrading to 2.5? And that’s strange I can’t find questions on google about it because the problem seems pretty serious to me but not many people are bothered by it.

I tried it multiple times without any issue. So it does not happen for everyone. At least not for me. I know it doesn’t help, but I don’t have too many ideas right know.

Anyway, thanks for the reply.
Asked my colleagues if they also face this issue and only one of them does even though all of us have the same hardware.