Docker Community Forums

Share and learn in the Docker community.

Blank dialog boxes after new docker install

bugfixes
usability
docker

(Bitwise101) #1

Hi,

I just opened Docker for Windows and it asked me to upgrade. Midway through upgrading, the process hung for over an hour. Ever since then, every dialog I get is a blank white screen as pictured in this link:

http://tinypic.com/r/2dvscgm/9

If I reboot, the whale in the tray says “docker is starting up” then I get the blank screen after a few minutes. Since then I’ve tried uninstalling and reinstalling the latest Docker community edition, but I keep getting the white box after every try. Please help.


(Bitwise101) #2

It’s like the user interface is not being drawn. System Restore won’t allow me to go back. I’m stuck. I don’t know what to do.


(Bitwise101) #3

C’mon, Y’all. This issue is holding me up in the worst way. I need some help with this.


(Bitwise101) #4

Microsoft Surface Pro 2
x64 8GB Ram
Windows 10 Pro 10.0.16299 Build 16299
Docker for Windows 17.12.0-ce-win47


(Bitwise101) #5

So I think I at least partially found a solution or workaround to this issue.

I hope this helps someone else facing a similar issue.

I read on a post somewhere that loading visual studio with power saving mode fixed an issue with it appearing in a blank white dialog box.

So I switched to a more robust power plan and I began to see the text and graphics in the edge install that was running on my machine.

I wanted the stable version, so I uninstalled the edge version completely with a powershell script I found.

When I ran the stable version installer, the dialog box was still blank. I remembered someone said to just restart after seeing this blank installer dialog. I waited 10 minutes for it to fully install then rebooted.

When windows started up, Docker was running and I could finally see the text, buttons, graphics in Docker for Windows’ UI.

I would say, this is still an issue that the devs at Docker need to fix or at least warn about as a prerequisite to installation especially since the installer window continues to be blank even with the more robust power settings.

Thanks


(Bitwise101) #6

Hi,
I’m having the issue of a blank white box when I choose settings or any dialog box from the Docker for Windows daemon despite the same power settings I thought solved the problem. I would greatly appreciate some help with this. Thank you!