Screen flashing black after installing Docker

Hello everyone, I’ve installed Docker on a new laptop (ASUS Proart Studiobook16 H5600QM), and as soon as i’ve done it my screen is flashing black at random moments. I’ve tried anything:

I tested if it’s actually docker causing the problem, and in fact it is: I’ve tried a fresh windows install using a flash drive, installing the drivers one by one by hand directly from the asus website, installing everything I usally install on a work pc (vs code, postman, xampp, remix, telegram, discord) and it works like a charm, but as soon as i install docker it goes crazy.

I have no idea why it happens, can someone help me resolving this issue?
Thanks in advance :slight_smile:

OS: Windows 11 Pro 22H2 build 22621.900
App version: 4.15.0
How to reproduce: install docker and wait like 10 seconds

Have you tried an older version? Is it only happening with the latest Docker Desktop (4.15.0)?

I updated to 4.15.0 only on my macOS. I will tr it later on my Windows, but 4.14.1 worked well.

I have 4.15.0 running on Windows.
My machine doesn’t behave like this.

Could it be another issue with wslg again?
This could be easily tested by stopping docker desktop and running any WSL2 distribution.