Docker Community Forums

Share and learn in the Docker community.

Broken Discourse forum UI, anyone?

Greetings,

I haven’t experienced this particular problem on any other Discourse forum I participate in so far and I’m wondering if anyone can reproduce the broken behavior I’m experiencing on the Docker forum:



I get roughly the same results on any of the following browsers:

Google Chrome Version 58.0.3029.110 x64 (latest)
Firefox 53.0.3 x64 (latest)
Firefox 48.0.2 x64
Firefox 46.0.1 x64

I don’t get the same result on mobile Chrome & Firefox but it is still problematic. When I touch the hamburger menu, I get a scrollable two line high menu and the rest of the space it would normally occupies is blank:



I am also unable to upload a file using the upload button or change my profile picture on any of my browsers (pc or mobile). When I try, I get the lightbox effect (kind of like a grey overlay that dims my screen) but nothing else; no buttons of any kind and only ESC will bring me out of it.

As I said I find it odd since I don’t experience this on any other Discourse forum. AdBlocker is disabled. No fancy extensions or Chrome Apps. Quite puzzling.

Thank you!

Denis

I’m also getting an empty lightbox when trying to flag spam

About the hamburger menu, when scrolling down, as soon as the thread topic header appears it goes back to normal behaviour.

But this is definitely not the expected behavior and not what I’m getting on other discourse forums I visit (gitlab, seafile etc.)

@codinghorror @samsaffron @discourse @dockersupport

This looks like a custom CSS issue to me? You might try disabling any
custom CSS rules that might affect this area.

Greetings @discourse,

Thanks for your reply.

I don’t have any custom CSS (that I know of) running on any of these browsers. Both Firefox version listed previously have no extensions and I’ve tried on mobile browsers with no extensions as well as incognito mode and I get the same or very similar results.

Would be willing to help troubleshoot it by going a bit deeper if I’d be given some directions.

Thanks again!

Can you try in safe mode… visit the following URL to hit safe mode

https://forums.docker.com/safe-mode

Does the issue show up there?

1 Like

Hello @samsaffron,

Thank you for your prompt reply.

Test:   https://forums.docker.com/?safe_mode=no_custom
Result: OK

Test:   https://forums.docker.com/?safe_mode=no_custom%2Cno_plugins
Result: OK

Test:   https://forums.docker.com/?safe_mode=no_custom%2Cno_plugins%2Conly_official
Result: OK

Test:   https://forums.docker.com/?safe_mode=no_custom%2Conly_official
Result: OK

Test:   https://forums.docker.com/?safe_mode=no_plugins%2Conly_official
Result: BROKEN

Test:   https://forums.docker.com/?safe_mode=no_plugins
Result: BROKEN

Test:   https://forums.docker.com/?safe_mode=only_official
Result: BROKEN

The Culprit: Docker’s custom theme, it seems.

Let me know if there’s anything else I can do to help pinpoint the problem / rule stuff out.

Thanks! :v:

Cool, perhaps @kizbitz can forward this to the right party then, thanks for debugging!

1 Like

@kizbitz

Doing a quick follow up: The hamburger menu seems to behave properly now which is great. :thumbsup:

I’m still experiencing the empty lightbox problem when trying to flag or use the upload button from the editor.

I also just noticed that the scrollbar suffers from the a similar ailment the hamburger menu had:

It’s blatantly stepping on the suggested topics footer’s turf! :smirk:

This post was flagged by the community and is temporarily hidden.