Docker Community Forums

Share and learn in the Docker community.

Builds not working anymore (Mercurial source repository on BitBucket)


(Bernhard Gschaider) #1

Hi!

I have a repository on docker.hub that is connected to a repository on BitBucket

This worked well 5 months ago (which is the last time I built some images) but now I wanted to update the images and I always get this error messag:

Building in Docker Cloud's infrastructure...
abort: error: [SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:590)
please ensure the correct public key is added to the list of trusted keys for this repository and the remote branch exists. (255)

I haven’t changed anything and builds that worked before did not work anymore. As it was suggestested somewhere else I tried to disconnect the BitBucket-account (and also removed the OAuth-keys on BitBucket). Then reconnected to BitBucket. But the error message is still the same

Does anyone have an idea what could be the problem?

Bernhard


#2

I have the same problem. It seems to be related to this. If that is the case, Docker hub may need to change the interface with Bitbucket to use TLS1.2 or 1.3.