Docker Community Forums

Share and learn in the Docker community.

Docker pull results in getsockopt: connection refused

(Jesse Adametz) #1

Expected behavior

Note: this output is retrieved from a docker-machine virtualbox on my laptop

{03:55 PM}~/Development ➭ docker pull hello-world
Using default tag: latest
latest: Pulling from library/hello-world

Digest: sha256:af451bc5c4d6e87b64303f707f7bd98debd7fd3175a676c08f4bf46cb48813d4
Status: Image is up to date for hello-world:latest

Actual behavior

Note: this output is retrieved from Docker for Mac on my laptop

{03:52 PM}~/Development ➭ docker pull hello-world
Using default tag: latest
Error response from daemon: Get Get dial tcp: lookup on dial tcp getsockopt: connection refused


Docker for Mac: version: mac-v1.12.0-beta17
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160630-155811.tar.gz
[OK] docker-cli
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

Diagnostic ID: ACD8C9C3-C447-4E58-8BCE-88C06112FA97

Steps to reproduce the behavior

  1. docker pull hello-world

Additional notes

This all worked as expected as recent as yesterday. While the issue occurs on my normal office wifi, it does not happen when I tether from my phone (as an example of another readily available network that I had). Other coworkers on the same office wifi are not experiencing this issue.

Docker run hello-world results in an i/o timeout
(Jesse Adametz) #2

Additional note: Everything seems to be fine on a different wifi network. I’m unsure what to track down as the problem with my work network (again, other co-workers don’t have this issue).

Is anyone able to tell me based on the uploaded diagnostic what I should look at? Thanks!

(Andreblum) #3

Same problem here. And thanks for the suggestion to try tethered mobile network. That works and is a good data point.
Additional info:
The WiFi and ethernet networks I can connect to both use as network, and the network is defined on our network, too. Docker chooses as the network address range, which conflicts with that. On other docker engines on our network, I have to use the --bip option to pick another range. I have not found a way to do that with Docker for Mac.

(Jesse Adametz) #4

The issue seems to have resolved itself for me overnight.

@docker: If there’s anything I can do on my end to help you guys track this down, just let me know.

(Jesse Adametz) #5

Just kidding. After a few hours it seems to have suddenly resurfaced.

(Jordan Beauchamp) #6

Had the same issue. Restarting the docker registry host network interface and its daemon service seemed to resolve it.

(Rafael Eyng) #7

Same here. Tried restarting the docker registry and didn’t work.

(John612) #8

I am having the same issue. I can run commands except I am unable to do a pull