Docker Community Forums

Share and learn in the Docker community.

Docker is unable to fetch images


(Martin Goyot) #1

Hello there,

I have an issue with docker for mac. I’m not able to download any image and thus prevented from running any container.

Command

$ docker run -ti busybox

Expected behavior

To actually run the busybox

Actual behavior

> $ docker run -ti busybox
Unable to find image 'busybox:latest' locally
docker: Error response from daemon: Get https://registry-1.docker.io/v2/library/busybox/manifests/latest: Get https://auth.docker.io/token?scope=repository%3Alibrary%2Fbusybox%3Apull&service=registry.docker.io: dial tcp: lookup auth.docker.io on 192.168.65.1:53: no such host.
See 'docker run --help'.

Information

Pinata output:

OS X: version 10.11.4 (build: 15E65)
Docker.app: version v1.11.0-beta8.2
Running diagnostic tests:
[OK]      docker-cli
[OK]      Moby booted
[OK]      driver.amd64-linux
[OK]      vmnetd
[OK]      osxfs
[OK]      db
[OK]      slirp
[OK]      menubar
[OK]      environment
[OK]      Docker
[OK]      VT-x
Docker logs are being collected into /tmp/20160423-194013.tar.gz
Most specific failure is: No error was detected
Your unique id is: 591862C2-FB7A-49C7-83F5-A57B1A3E944E
Please quote this in all correspondence.

If you have any idea…


(Martin Goyot) #2

Okay, so I’ve found out it has something to do with my internet box, but what… If I use my vpn which is a basic openvpn tunnelling, then the docker works perfectly. As soon as I shut it down, it does not work anymore, ending up with the same error described above.

I tried from another wifi spot and I do not have the same issue so it looks like the problem comes from my box, but what… If you have any idea…


(Martin Goyot) #3

So, Since tonight update everything is working fine. Maybe there was something wrong beforehand. I don’t know how/if we can close topic.


(Micahzoltu) #4

Both me and my co-worker running Docker for Mac and Docker for Windows are experiencing this issue, new as of this morning (was working fine on Friday for both of us).

Tips on the internet suggest restarting docker-engine, but I don’t know how to do that for the new native docker clients.


(Esteban) #5

Same here, issue came up this morning.


(Esteban) #6

As a workaround, falling back to docker-machine works fine.


(Sasha Vinčić) #7

Had the same problem on my MacPro which only has WiFi connection. It seems that if you enable “Start docker at login” it starts before the machine is online and something goes wrong. Not even a restart resolved it.

If I disabled “start at login” and manually started it after logging into my machine, it worked again.