Cannot get Docker working in Macbook Pro M1 (again)

I also recently got a Macbook Pro with M1 Pro processor and have tried to install Docker. Like @vmkiili I have little experience with Macs. I’ve downloaded the apple silicon version of Docker (several times), but when I run it, I get an error.

Fatal Error

com.docker.backend cannot start
Exit Code 101

(Reset Docker to factory defaults) (Diagnose & Feedback) (Exit)

Unlike the other post, I do not have either ~/Library/Group Containers or ~/Library/Containers folders.

The Reset Docker to factory defaults runs some process and then eventually quits with no further messaging.

Feedback & Diagnose sends me to the help page which seems to be more helpful once the application is actually running.

I’ve also tried installing Docker from the command line using these commands:

sudo hdiutil attach Docker.dmg
sudo /Volumes/Docker/Docker.app/Contents/MacOS/install
sudo hdiutil detach /Volumes/Docker

But I get this error when running the 2nd after several minutes:

Error: checking context having canceled: context deadline exceeded
Usage:
  install [flags]
1 Like

Same exact issue here, was running for a while and then I think after upgrading to Ventura, issue started

Found the fix here # cannot launch docker desktop for mac - Stack Overflow