Cannot get Docker working in Macbook Pro M1

I recently got a Macbook Pro with an M1 Pro processor and I tried to install Docker. I have no previous experience about Macs, but I’m learning and I’m getting help from a co-worker. However, I cannot get Docker working. I installed the Apple silicon version of Docker, but it doesn’t seem to work. When I double-click the Docker icon, nothing happens. The whale icon doesn’t appear in task bar. Docker daemon isn’t running. There is a Docker task in the Activity Monitor, but eventually the process name turns red and there is “(Not Responding)” text after the process name.

I don’t know what to try next. I have tried uninstalling and reinstalling Docker, but it makes no difference.

Any ideas? I’m not very familiar with Docker in Windows either, so I don’t know how to debug this kind of problems.

Here is the log from Library/Containers/com.docker.docker/Data/log/host/Docker.log.

time="2022-02-04T14:27:18Z" level="info" msg="GoBackend: Launching Process /Applications/ -watchdog -native-api"
time="2022-02-04T14:27:18Z" level="info" msg="GoBackend: com.docker.backend launched with PID 21778"
time="2022-02-04T14:27:18Z" level="info" msg="GoBackend: status Pinging"
time="2022-02-04T14:27:18Z" level="info" msg="IPCClient: 4a63510c-GoBackend (00dd6478) C->S GET /ping"
time="2022-02-04T14:27:18Z" level="info" msg="DevEnvsBackend: Launching Process /Applications/ -watchdog"
time="2022-02-04T14:27:18Z" level="error" msg="IPCClient: 4a63510c-GoBackend (00dd6478) C<-S GET /ping (1.811981ms): Request failed: no response"
time="2022-02-04T14:27:18Z" level="info" msg="DevEnvsBackend: launched with PID 21779"
time="2022-02-04T14:27:18Z" level="info" msg="ExtensionManagerBackend: Launching Process /Applications/ -address /User
s/vmkiili/Library/Containers/com.docker.docker/Data/extension-manager.sock -watchdog"
time="2022-02-04T14:27:18Z" level="info" msg="ExtensionManagerBackend: com.docker.desktop-extensions launched with PID 21780"
time="2022-02-04T14:27:18Z" level="info" msg="CrashReport: stderr redirected to /Users/vmkiili/Library/Group Containers/"
time="2022-02-04T14:27:18Z" level="info" msg="DevEnvsBackend: ⇨ http server started on docker-dev-env-api.sock
time="2022-02-04T14:27:18Z" level="info" msg="ExtensionManagerBackend: Starting Desktop Extension Manager
time="2022-02-04T14:27:18Z" level="fault" msg="GoBackend: Notified of unexpected termination of com.docker.backend"
time="2022-02-04T14:27:18Z" level="fault" msg="GoBackend: 0   Docker                              0x0000000100866748 $s6Docker14WatchedProcessC05startC033_CB5922B1013A2ABA2B
B8EAD3D4DF3136LLyyFySo6NSTaskCcfU0_ + 316
1   Docker                              0x00000001008665f8 $sSo12NSFileHandleCIegg_ABIeyBy_TR + 36
2   Foundation                          0x0000000187cfe494 __45-[NSConcreteTask launchWithDictionary:error:]_block_invoke_2 + 40
3   libdispatch.dylib                   0x0000000186b1ce60 _dispatch_call_block_and_release + 32
4   libdispatch.dylib                   0x0000000186b1ebac _dispatch_client_callout + 20
5   libdispatch.dylib                   0x0000000186b3043c _dispatch_root_queue_drain + 684
6   libdispatch.dylib                   0x0000000186b30b58 _dispatch_worker_thread2 + 164
7   libsystem_pthread.dylib             0x0000000186cd92c8 _pthread_wqthread + 228
8   libsystem_pthread.dylib             0x0000000186cd8018 start_wqthread + 8"

Can you find more error message in this file?

I already have Docker on my Mac M1 and I don’t remember if I had to configure anything. I guess I just downloaded the file and clicked on it. Some apps require additional steps like right clicking on the dmg file, then clicking on “open”. Then it asks you if you trust it. Since you have your log files, I don’t think it is the case.

This is the contents of that file:

2022-02-04 16:56:31.551 Docker[24593:230776] [Bugsnag] [INFO] Last run terminated during an app hang.
2022-02-04 16:56:31.555 Docker[24593:230776] [Bugsnag] [INFO] Sending launch crash synchronously.
2022-02-04 16:56:31.990 Docker[24593:230810] [Bugsnag] [INFO] Sent session C3277410-C241-4BEB-92DC-2664EEB1421B
2022-02-04 16:56:34.224 Docker[24593:230863] [Bugsnag] [INFO] App hang detected

I also tried Intel binary just for fun, but it had identical behaviour.

I finally managed to get it running! I removed the installation and ran these commands:

rm -rf ~/Library/Group\ Containers/
rm -rf ~/Library/Containers/com.docker.docker
rm -rf ~/.docker

I noticed that .docker directory was owned by root user, so I had to use sudo to remove it.


Thank you for this - it helped me out with Docker not starting for me.

1 Like

I made an account here just to say thank you so much for this! It worked out great.

This fixed my issue. Thank you very much

Amazing, worked like a charm. I downloaded the wrong Mac version, needed Apple chip but downloaded and ran Intel chip initially. I tried to uninstall it and install the Apple chip, but clearly I missed something. This solution solved it for me. Very grateful.

This worked for me as well. Thank you for posting the solution!

Thank you, without your post I would have been clueless otherwise. Much appreciated!

Thanks , This way really helped me to runing Docker again!

rm -rf ~/Library/Group\ Containers/
rm -rf ~/Library/Containers/com.docker.docker
rm -rf ~/.docker

I noticed that .

the given suggestion does not work for me.

i have uninstalled Docker, performed the folder removals, reinstalled again. also these steps in different order. also done all those steps with reboots inbetween.

but docker-desktop will not launch when clicking its icon.

HOWEVER when i right-click it, and “show package contents”, then open the folder Contents/MacOs, and then i click on the Docker unix executable file (so not the “Docker”), then the main window appears with the status “Docker desktop is stopped…” and then closes once again.

(i once had it that the status went to “Docker is starting…” and then it looked OK, but as soon as i tried using the deamon it closed again)

edit: the above was on Docker 4.15.0
i downgraded to 4.11.1 and it works again

Had the same each time I upgrade, just upgraded to 4.15.0 (93002), same thing, after the upgrade clicked on the Docker icon, nothing happened.

To resolve I just restart the mac. and when it has restarted it works.

Not running M1 , just old 2.3 GHz Dual-Core Intel Core i5

Thanks for the post and suggestions here. I guess my situation was a little bit different: New M1 restored from Time Machine Backup from Intel machine.

First difference here is Intel vs ARM build, so I did remove Intel Docker and reinstalled ARM Docker build – I may or may not have been helped by vmkiili’s popular suggestion above.

However, my Docker still wouldn’t successfully launch. Activity Monitor showed Docker as Unresponsive and that was that. I eventually ran the softwareupdate --install-rosetta as suggested by Docker docs > System Requirements: Mac Silicon. I don’t know that I’m completely out of the woods, yet, but at least now no errors, icon shows in menu (as loading), and Dashboard does show.

Hope this helps someone.

1 Like

Hello all, I have a macbook pro m1 and I have been using docker for the last 2 years, suddenly I am unable to reach, no matter what I do docker pull, docker push I get the following error

docker “”: net/http: request canceled while waiting for connection (client.timeout exceeded while awaiting headers)

I ran the following

rm -rf ~/Library/Group\ Containers/
rm -rf ~/Library/Containers/com.docker.docker
rm -rf ~/.docker

I have re-installed docker

All to no avail

Please someone help work has stopped abruptly

For proper reinstalling you can watch my video on YouTube: Uninstalling Docker Desktop properly on macOS - YouTube
It alread helped some people.

In case it is not the issue, the question is what changed in your environment. Did you update Docker Desktop? Has anything changed in your network? New home, new network or new company, new proxy?

Thank you a lot! It helped me so much. I was trying to open my Docker for one day