Cannot run "docker version" in command prompt

I am having problems running docker in a command prompt (I run the command prompt as an administrator). I tried docker on both Windows 10 Pro, Version 1511 and 1607.

Microsoft Windows [Version 10.0.10586]
© 2015 Microsoft Corporation. All rights reserved.

C:\windows\system32>docker version
Version: 17.06.0-ce
API version: 1.30
Go version: go1.8.3
Git commit: 02c1d87
Built: Fri Jun 23 21:30:30 2017
OS/Arch: windows/amd64
error during connect: Get http://%2F%2F.%2Fpipe%2Fdocker_engine/v1.30/version: open //./pipe/docker_engine: The system cannot find the file specified. In the default daemon configuration on Windows, the docker client must be run elevated to connect. This error may also indicate that the docker daemon is not running.

I installed docker. I wasnt able to get it work with hyper-v/ I disabled hyper-v. Reinstalled and am using virtual box. And I get the same error.

When use quick start terminal, i do not get these errors.


I found the answer here.