Cant create team in organization?

I keep trying to create team names under my organization but no matter what I name the team as or describe it as I get the message “Please check your input values. The team name may already exist or the characters may be invalid.”

I have only one organization and no teams (other than “owner”) in existence.

Thank you,

Hey neigbor!

That is certainly unexpected behavior. Does it do the same thing in different browsers?

Also, for this sort of thing, it’s not a bad idea to send in an email to, and include as much information as possible.


It happened to me as well. I tried to create a team in my org called “AMP”. I was successfully able to create it with all lowercase: “amp”. The UX around this could be improved since there is really no guidance provided, no validation until you try to save, and no hint about what’s wrong with the name.

1 Like

I am also encountering this issue. I can’t create any teams even though the only team that exists is “owners”

what team names are you trying to create?

I think the error occurs if there are capitalized letters in the name. I lowercased them and was able to create the team.

I had the same issue. Uppercase characters all resulted in “invalid characters” switched to all lowercase and it worked.

I’m experiencing this issue. Lowercase/Uppercase doesn’t change

I also had this issue. In case it’s helpful, by inspecting the Network request in chrome dev tools, the error message returned by the request was “group name must be between 3 and 30 characters, and contain only lowercase letters and numbers”