Docker Community Forums

Share and learn in the Docker community.

Can't even get going.. network setup error?

So I’ve tried this a few times. This is on Windows 10. On running the Docker Quicstart Terminal, I get:

Starting “default”…
(default) Check network to re-create if needed…
Error setting up host only network on machine start: host-only cidr conflicts with the network address of a host interface
Looks like something went wrong in step ´Checking status on default´… Press any key to continue…

I’ve tried removing Docker Toolbox and Virtualbox, as well as all the virtual network devices, and letting it all reinstall. I have no idea what this error means, or where to go, and search hasn’t shown anything close to this error.

Crap - so another search found the issue. It looks like Docker Toolbox is defaulted to set the virtual subnet as 192.168.99.0/24, which is what my LAN uses, so it conflicts. Is there a way to change this behavior? Or is my specific IP range of my network preventing me from using docker toolbox?

Okay, so I found a solution - I think… I had to add the --virtualbox-hostonly-cidr “x.x.x.1/24” command to choose a new default subnet - but took quite a few tries to figure out how to do that. I had to modify start.sh, and add it into the docker-machine create command line. Looks like I’m okay for now, but this really should be documented better, or better yet, autochoose a different range if that IP already exists!

Hey. I’m having exactly the same issue. Could you please give me some more detail on the update to start.sh which you made?

Thanks.

Same issue here. Any help would be much appreciated.
Thanks.

For future reference, I fixed this issue by removing the default machine and recreate it with specific IP

docker-machine create -d virtualbox --virtualbox-cpu-count=2 --virtualbox-memory=4096 --virtualbox-disk-size=50000 --virtualbox-hostonly-cidr “192.168.33.1/24” default

Works fine now.

Solved …
I was working with Docker Toolbox on Windows Host,
For me “Npcap Loopback Adapter” was assigned with static ip of 192.168.99.1
I just browsed to
Control Panel\Network and Internet\Network Connections

Then converted “Npcap” adapter TCP/IPV4 Address to “Obtain an IP address Automatically”
and it worked like a charm.