Docker Community Forums

Share and learn in the Docker community.

Can't find or pull public repos on docker hub


(Wen Qiushi) #1

Hi, I’m new to docker and I encountered this problem last week.

I create a public repository on docker hub:
https://registry.hub.docker.com/u/wings27/centos-web-dev/

And I can see that repo under the Summary tab:https://hub.docker.com/u/wings27/

But the question is that I can’t find anything under the Repository tab:https://registry.hub.docker.com/repos/wings27/

It says

No repositories found.

Also, searching the repo results in nothing:https://registry.hub.docker.com/search?q=centos-web-dev

And I can’t pull or push from/to the repo either.

When try pulling, docker CLI says:

FATA[0009] Repository not found

And when I try pushing, docker CLI says:

FATA[0001] Repository does not exist: docker.io/wings27/centos-web-dev

Strangely, on docker hub summary page, the Number of Pulls increases every time I pull. Also Activity Feed logged that pull.

The Number of Pulls of repository wings27/centos-web-dev is 12 by now, but I have NEVER successfully pulled the repo, every time I get the save error: "Repository not found ".

The question is also available at http://stackoverflow.com/questions/30661879/docker-pull-fails-not-found-yet-number-of-pulls-increases

Please help me.
And sorry about the broken links, but new users can only post up to two links.

Extra info:

[root@localhost:/]# docker version
Client version: 1.6.0
Client API version: 1.18
Go version (client): go1.4.2
Git commit (client): 8aae715/1.6.0
OS/Arch (client): linux/amd64
Server version: 1.6.0
Server API version: 1.18
Go version (server): go1.4.2
Git commit (server): 8aae715/1.6.0
OS/Arch (server): linux/amd64

[root@localhost:/]# docker info
Containers: 18
Images: 20
Storage Driver: devicemapper
Pool Name: docker-253:1-68344374-pool
Pool Blocksize: 65.54 kB
Backing Filesystem: xfs
Data file: /dev/loop0
Metadata file: /dev/loop1
Data Space Used: 1.66 GB
Data Space Total: 107.4 GB
Data Space Available: 49.35 GB
Metadata Space Used: 2.863 MB
Metadata Space Total: 2.147 GB
Metadata Space Available: 2.145 GB
Udev Sync Supported: true
Data loop file: /var/lib/docker/devicemapper/devicemapper/data
Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
Library Version: 1.02.93-RHEL7 (2015-01-28)
Execution Driver: native-0.2
Kernel Version: 3.10.0-123.el7.x86_64
Operating System: CentOS Linux 7 (Core)
CPUs: 16
Total Memory: 31.25 GiB
Name: localhost.localdomain
ID: 3V6G:TZAX:HL4O:LLXR:VFIW:2SA6:YX4N:LV62:BUIN:Z2EE:7CTX:P65H
Username: wings27
Registry: [https://index.docker.io/v1/]


(Jerry Baker) #2

Hi Wen,

On your local machine where you’re running the Docker CLI what is the output of:

cat /etc/*release

Thanks,

Jerry


(Wen Qiushi) #3

Hi, Jerry.

The output is:

[root@localhost:~]# cat /etc/*release
CentOS Linux release 7.0.1406 (Core)
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL=“https://bugs.centos.org/

CentOS Linux release 7.0.1406 (Core)
CentOS Linux release 7.0.1406 (Core)


(Jerry Baker) #4

Hi Wen,

I believe there is an issue with your binary. Could you replace it with our build and try again?

sudo systemctl stop docker
sudo mv /usr/bin/docker /usr/bin/docker.original
sudo curl https://get.docker.com/builds/Linux/x86_64/docker-latest -o /usr/bin/docker
sudo chmod +x /usr/bin/docker
sudo systemctl start docker

Thanks,

Jerry


(Wen Qiushi) #5

I tried as you told but it still doesn’t work.

The output:

[root@localhost:~]# docker login
Username (wings27): wings27
WARNING: login credentials saved in /root/.dockercfg.
Login Succeeded
[root@localhost:~]# docker pull wings27/centos-web-dev
Pulling repository wings27/centos-web-dev
FATA[0006] Repository not found

What confuses me is that I can’t find the repo I just created on docker hub. I can only see it under the Summary tab, but not in My Repositories, or in the Search page.
https://registry.hub.docker.com/repos/wings27/

So I don’t think it has anything to do with docker CLI. After all, this problem happened without using docker CLI at all.


(Jerry Baker) #6

I think there was an issue with your binary so you should be good with that piece now.

As far as your latest problem:

It looks like your two repositories are empty. They don’t have any tags. Have you pushed anything to them yet?

You won’t be able to search or pull until the repository has something pushed to it.

Jerry


(Wen Qiushi) #7

Yes, that makes sense.
I’ve tried pushing again, and it was successful. Thank you so much.

Although it might seem a little bit confusing for a git user that you can’t search or pull an empty repository. :smile:

I’ll read the documentation more carefully next time. And thanks again. Have a good day!