Docker Community Forums

Share and learn in the Docker community.

Can't login to docker Hub

build

#1

Hello,

It’s the first time i work with docker. I would like to build my own docker image to publish it to my heroku project. Then i create a private repository on my docker hub account, i created my docker-compose (apache, php and mysql). I build it, but i stuck to push it on my repository.
After build it, i run the command to push images: “docker-compose push”: this command returns me the following errors: “ERROR: denied: requested access to the resource is denied”.
I think that’s normal, because i am not logged to my account and the repository is private, the i attempt to login. The i run the command “docker login”, enter my username and passaword, but my linux software (my distribution is kubuntu) couldn’t save my credentials: "Error saving credentials: error storing credentials - err: exit status 1, out: Error calling StartServiceByName for org.freedesktop.secrets: Timeout was reached".

What could i do ?

Thanks for help


(Fsejoseph) #2

Are you in root? If not, have you added yourself to the docker group?


#3

What do you mean by group and root ?

I tried with the commands with sudo, no matter :confused: and i created the docker hub by myself …