Can't make docker run containers in Ambrian on my Asus Tinkerboard

trying to verify my docker installation by running the hello-world container but getting this error message:

sudo docker run -d --name hello hello-world

docker: Error response from daemon: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error setting cgroup config for procHooks process: bpf_prog_query(BPF_CGROUP_DEVICE) failed: function not implemented: unknown.
docker --version
Docker version 20.10.21, build baeda1f
uname -a
Linux tinkerboard 5.15.74-rockchip #22.08.6 SMP PREEMPT Tue Oct 18 06:40:37 UTC 2022 armv7l armv7l armv7l GNU/Linux
lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04.1 LTS
Release:	22.04
Codename:	jammy


  • Asus Tinkerboard
  • Kinston SSD 500gb (system)
  • Sandisk SD 32gb (boot)

Tried installing docker with apt, softy and curl. But same result everytime

Tried Tinkerboard Debian, Armbian and at last DietPi which worked right otb. :smiley:

1 Like