Can't pull on own server (no space left)

I’m running a pipeline on Gitlab every time I do a push to master. This pipeline is quite simple:

image: docker:latest
  - docker:dind
  - docker login --username="myUSER" --password="myPASS"
  - Pull
  stage: Pull
    - deploy # private runner on server
    - docker pull $DOCKER_IMG

This pull is a 1-2GB image from Docker Hub and it’s connected with a private runner so this detects I want to pull on my server (no ssh connection required).

The issue that I get when I run this is that I don’t have any more space on my server.
This is the available space that I’ve got:

recipic@recipic:/var/lib/docker$ sudo df -h /
Filesystem      Size  Used Avail Use% Mounted on
/dev/vda1        20G  6.4G   13G  34% /

Here you can see further info:

I’m also talking with DigitalOcean staff and they told me that this is quite weird. Also previous link is on Gitlab forum to discard problems from them as well.

On my server I’m using Docker version 17.03.0-ce, build 3a232c8 on Ubuntu 16.04

Post created on Docker repository:

Am I doing something wrong? :S

I’m getting the same error on AWS since 2 hours

Interesting I can confirm I can pull from DigitalOcean so this looks like more related with Gitlab. I also created a post on docker about this (updated comment above):

Can you post your comment there as well?

I’m using Github and I’m getting the same issue.

So it’s not Gitlab. Are you using some kind of CI?

For me it’s just dockercloud + AWS, and the I’m getting and no space left on device error on docker cloud CI tests.

Your implementation sounds even more usual than mine. Could you provide this info on Github issue as well please?