Docker Community Forums

Share and learn in the Docker community.

Change default networking from "Host-only Network" to bridged with VB provider


(Salam Y. ELIAS) #1

When the default machine is started in the terminal, it adds or use a Host-only Network adapter.
I need this default VM to communicate to other machines rather that only with the host, how this can be done?
Thanks


(Salam Y. ELIAS) #2

while doing some search in docs.docker.com, I came across this for VB provider

To customize the host only adapter, you can use the --virtualbox-hostonly-cidr flag. This will specify the host IP and Machine will calculate…

It does not indicate how to change and not use virtualbox-hostonly
Regards


(Salam Y. ELIAS) #3

Can somebody from Docker team respond by YES or NO if this feasible so we can stop our efforts

I am wondering if this forum is dead or alive, since 10 days, I posted a couple of messages and it seems nobody is taking care of this forum


(Mano Marks) #4

@eliassal Please clarify what you’re trying to achieve. By default a Docker Machine using the VirtualBox driver will have an IP address and is available to apps outside it.


(Salam Y. ELIAS) #5

Mano, when using Kitematic, a linux machine is cretaed called “default” and the process creates a “Host-Only adaptateur” with network subnet 192.168.99.0/24., the default machine gets an IP of 192.168.99.100
Only the hosting windows machine (which is on my subnet (192.168.1.5) can communicate with this adresse, for example, when I spin a mailhog container, I can do http://192.168.99.100:8585 and it works fine but I can not do 192.168.1.5:8585, it does not work as the container is inside the linux machine.

What I need to do is change network adapter to something different than “Host-Only adaptateur” , lets say, virtualbox terminology, Bridged or nat as other VMs running under virtualbox so all my machines in the subnet 192.168.1.0/24 can communicate with the container.

The "Host-only adapter allows only communication between the VM and the host. I tried to do a workaround by using IP forwarding between the 2 subnets on the hosting machine but it seems that routing in win 10 does not work (confirmation on one of the technet forums)
Thanks for your help


(Apquinn) #6

I have exactly the same question. Has this been answered?


(Tftcoelho) #7

Have you tried this approach? https://stackoverflow.com/a/36458215
This is about port forwarding. I guess you may try to add a new port forwarding rule to the port 8585.
Please tell how it worked for you.

I’ve tried this but couldn’t fix the problem