Docker Community Forums

Share and learn in the Docker community.

Clicking "Web Preview" will not work when I am mounting a local host volume


(Mosthated) #1

Hello all, I tried to open a container using this command

docker create --volume //c/Users/dterm/Documents/WorkSites:/var/www/html eboraas/apache-php:latest

but when I do I can not click on web preview, so I can not figure out what port is being used to try and view my site. If I remove the mounted volume it then works, but I then can’t see the local files I am working on through apache in the container. Does anyone know what might be the cause?

On windows 10, newest versions of all software. There may be more to it then this that is wrong, when I start a container, I don’t have any way to edit volumes or files or anything, the volume tab is empty with nothing to click on unless I run the above command. No new or other ones have any shared folders except for “hello-world-nginx”.


(Mosthated) #2

Looks like I got it, under ports, the color of the box was the same color as the background so I didnt see you could click there and type something in, once I put that in there, I was able to get to the site!


(Michael Friis) #3

For others encountering this problem, could you provide more details (or perhaps post a screenshot) on how you resolved the problem? Where you using Kitematic?