Docker Community Forums

Share and learn in the Docker community.

Confused newbie seeking some help

I installed Docker Hub and found myself to a docker-tutorial. I’m running a Windows 10 Pro 64-bit PC and followed instructions to install. There I have two repositories that are Linux OS. Did I miss something? Should they have been Windows 10? One was a docker getting-started tutorial. I’m pretty sure I created the second repository while following the tutorial. It’s also Linux.

I also have Docker Desktop installed. I don’t think that’s the same thing. The Docker Desktop shows tutorial and another repository but the two repositories in the Docker Hub Dashboard don’t correspond in name to the ones on Docker Desktop.

I’m confused. I am able to check the docker version from my Windows command line. I can push to the getting-started repo that I see on Docker Hub Dashboard, but I don’t know if I can start those in the dashboard and show them on the browser.

The tutorial (which I access from the Docker Desktop) tells me that I ran this command: docker run -d -p 80:80 docker/getting-started to open it on my browser. I see that it is actually a Github repository. Am I reaching the same repositories even though they show different names? If I run that command from the windows cmd, it opens the same as when I open

I’m not sure how, but I also have a shortcut on my desktop named Docker Quickstart Terminal. When I click on that it opens a command line window but I don’t know if it is the windows command line. It reads “Running pre-create checks…” Then, “Error with pre-create check: “This computer is running Hyper-V. VirtualBox won’t boot a 64bits VM when Hyper-V is activated. Either use Hyper-V as a driver, or disable the Hyper-V hypervisor. (To skip this check, use --virtualbox-no-vtx-check)”
Looks like something went wrong in step ´Checking if machine default exists´… Press any key to continue…”

Now, I was told to enable Hyper-V, when installing Docker. I can’t run that recommended skip check command, and pressing any key does not continue at all. When I click enter, the terminal disappears.