Docker Community Forums

Share and learn in the Docker community.

Hyper-V error when starting Docker Quickstart Terminal for the first time


(Bdphil86) #1

I just installed Docker on a Windows 10 machine for the first time so that I can start playing around with it. And, when I click the “Docker Quickstart Terminal” (running with elevated privileges), I get an error regarding Hyper-V:

Is there a solution to fix this? I manually created a VM via command-line, named it “default”, and it seemed to have created perfectly well, but then when I run “Docker QuickStart Terminal” again, it deletes the machine.

Any help here would be awesome. I expected this to work with Hyper-V straight out the gate.


(Bdphil86) #2

Tried this on a MAC with no issues.

I tried disabling hyper-v. It was just re-installed during pre-checks.


(Bdphil86) #3

I fixed this myself…“thanks”…I guess.


(Michael Friis) #4

@bdphil86 awesome, thanks for following up. If you don’t mind, could you post your solution here so that others that stumble on this post can learn what to do?


(Greenymcduff) #5

You need to disable Hyper-V (Turn it off in windows features)

Restart your pc then try again - fixed the issue for me :slight_smile: